3

I made an OS X 10.6 USB stick and I used it to succesfully install OS X on several Mac, including a very old Mac Mini and a MacBook Pro.

However I've got a problem: on my girlfriend's Mac it simply doesn't work.

When I hold ALT when the system boots up, I can see the harddrive icon (so I take it that pressing ALT does indeed work) and hence decide to boot from the harddrive, but I don't see the "Recovery HD" nor the USB stick / "EFI boot" icons. The only choice is get is "harddrive".

I tried again on my Mac Mini and surely enough: I can hold ALT and I see all the icons.

I also tried again on my MacBookPro (very old 17" MBP, the first 17" one if I remember correctly) and once again, I can hold ALT and I see the "EFI boot" icon.

Why doesn't my girlfriend's MacBook recognize the USB stick (and hence prevents my from reinstalling the system)?

The strange thing is that as far as I can tell my girlfriend's MacBook is more recent than both my MacMini and my MacBook Pro.

  • Could you provide the exact model of your girlfriends MacBook? Can you try to plug the USB stick into a different port? – Lee Joramo Jul 1 '14 at 19:45
1

If her MacBook was shipped with Lion, you couldn't be able to boot with a Snow Leopard stick. Apple Knowledge Base states that you shouldn't use earlier versions of OS X:

Note: You should not use a version of Mac OS X that is earlier ("older") than the version your Mac shipped with.

If this is the case, you have to create a bootable Lion stick.

  • On the other hand, if it is running Lion or ML, it should have the "Recovery HD"; which he said it does not. – Kent Sep 25 '13 at 0:50
0

It may depend on the exact version of 10.6.x you have. The "general" OSX install disc that Apple sold (not tied to any specific hardware) only includes 10.6.3; but, later models were pre-installed with 10.6.7, and they will not boot from the 10.6.3 DVD or USB.

You can use http://www.appleserialnumberinfo.com/Desktop/index.php to find out what OS the computer was originally shipped with.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .