I have a 16gb SanDisk Cruzer Fit USB thumb drive. It's plugged into a powered hub, along with an external HDD - at the end of the day, I unmount (eject) the drives, and disconnect the MacBook from the hub to bring it home. I wait until the Macbook is actually in sleep mode.

When I reconnect the hub in the morning, the HDD mounts without any fuss, but the thumb drive will not mount unless I power down the hub and then power it back on, or remove and re-insert the thumb drive. I have reset the NVRAM, this did not help.

The drive is formatted as Mac OS Extended (Case-sensitive, Journaled), and the system is a MacBook 2ghz Core i7 running 10.7.5. The USB device does not show up in diskutil, but shows up in System Information:

Firebird USB Flash Drive:

  Product ID:   0x5571
  Vendor ID:    0x0781  (SanDisk Corporation)
  Version:   1.26
  Serial Number:    4C532000020216123405
  Speed:    Up to 480 Mb/sec
  Manufacturer: SanDisk
  Location ID:  0xfa134000 / 10
  Current Available (mA):   500
  Current Required (mA):    200

Is there a way to get the drive to mount automatically without depowering the hub? (This is actually easier than re-inserting the tiny drive). Restarting the Macbook daily is generally not a desirable option for a variety of reasons.

I have sleepwatcher installed, but I'm not certain how to resurrect a drive from the command line when it's not available through diskutil.

  • Do you sleep the Macbook or shut it down before bringing it home? Have you tried another powered hub? Does the thumb drive mount just fine when directly attached to the Macbook? – IconDaemon May 9 '13 at 12:04
  • The process is thus: 1) Eject the disks, and wait for them to disappear from the finder tray, 2) Unplug the hub, display, ethernet and power 3) Close the lid to put it into sleep mode. I generally plug everything back in before opening the MacBook the following morning. Putting the Mac to sleep, and then unplugging and then plugging the hub back in before waking it results in a warning about removing the drive without ejecting, and the drive remains unmounted. (USB HDD mounts in all cases - it's just the thumb drive giving me fits.) I just tried it without the hub, and same deal. – RI Swamp Yankee May 9 '13 at 12:40
  • Perhaps the thumb drive is wonky. Have you tried another? I would also suggest you shutdown the Macbook instead of sleeping it, then remove all the peripherals. Is there any compelling reason to sleep rather than shutdown other than waiting ~60-90 seconds for the restart? – IconDaemon May 9 '13 at 17:21

You must log in to answer this question.

Browse other questions tagged .