1

I have bought a new MacBook Pro with Retina display which has OS X 10.8.3. I have installed MacFusion from the version on their website, but I cannot mount it, getting this error: Could not mount filesystem: Mount process has terminated unexpectedly.

Can you help me with that?

0

I ran across a post from the developer of WingFS pointing out his BSD licensed software will work on 10.8 to mount not only SFTP, but other services as well. I had tried macfusion2 which was failing.

WingFS worked the first time, and so I can GBTW. It's at http://wingfs.com for those that are interested. It doesn't seem to have every feature but it got the job done, with a UI that worked!

  • That is perfect! working like a charm :) – Rozita Akrami Oct 2 '13 at 7:21
2

Unfortunately Macfusion no longer works, it hasn't been maintained in a long time. Newer versions were around for a while but as near as I can tell, none of them work anymore either. Your best bet is a commercial product which can mount FTP or WebDAV disks such as Transmit. For mounting disks via SSH, I believe we're out of luck.

Such is progress.

  • 1
    Transmit can mount disks over SSH. – Warren Pena Jun 7 '13 at 22:54
1

Macfusion has been forked on GitHub by another developer and a pre-2.1 development build is available that operates under Mountain Lion with no issues yet that I've discovered; both SSHFS and FTPFS work with FUSE for OS X if the MacFUSE compatibility layer is installed.

If you're feeling adventurous, you can download the build or build it yourself from https://github.com/ElDeveloper/macfusion2.

Alternatively, the original Macfusion 2.0.4 can also be convinced to work again as a front end for SSH mounts and this works under ML, if you also install FUSE for OS X and SSHFS (also available from the same site), then modify it so that the sshfs-static binary points to the one from SSHFS, by running the following commands in Terminal:

cd /Applications/Macfusion.app/Contents/PlugIns/sshfs.mfplugin/Contents/Resources
mv sshfs-static sshfs-static.orig
ln -s /usr/local/bin/sshfs sshfs-static

However, it's a bit finicky. Mounting and unmounting SSHFS filesystems works fine, but attempting to remove a filesystem from the Macfusion list will fail.

I am unaware of a way to re-enable FTPFS functionality in Macfusion 2.0.4.

More information: SSHFS Installation: Macfusion

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .