4

I've been using this Macbook Pro for about 2 years now and recently got an external display for it. It is connected via a Thunderbolt to HDMI adapter.

Before I got the display, I could simply shut the lid to enable clamshell mode and the system would mostly power down (HDD would stop etc).

However, now whenever I shut the lid, the external monitor becomes the primary display and continues to work and keep the laptop awake. I do not have an external mouse, trackpad or keyboard connected.

Is there any way to make the laptop go back into clamshell when the lid is shut and turn both displays off? I would prefer if it were possible without disconnecting the external display, as every time I do that I lose my window arrangement across displays.

I found this, but I don't want point two. I want both displays to wake up when I open the lid, and both displays and the mac to sleep when I close it.

2

It may be easier to use the "Sleep" option in the  menu (upper, right). It sounds like the "clamshell mode" you're talking about is actually "Sleep mode" to the computer. I believe that this is the most effective way to get things into "sleep mode."

Other options:

  • Setup a "hot corner" that puts everything to sleep.
  • Use keyboard commands for sleep. (Command + Option + Eject)
  • 1
    Hmm. This might work, but I'd prefer the option of having the lid down. I live in India, which is fairly dusty and humid, and by shutting the lid I can prevent stuff from getting in through the keyboard and top vent. Already ruined the logic board once because of that. – Raghav Sood May 7 '13 at 14:10
  • You can put it to sleep and then close the lid. It should do the same thing. – gotshallmaxon May 7 '13 at 14:47
2

You are confusing sleep and clamshell mode. Clamshell mode means using a laptop with an external display while keeping the lid closed.

Anyway, clamshell mode behaved differently in 10.6 and earlier:

  • Closing the lid put a laptop to sleep even when the laptop was connected to an external display
  • To use the laptop in clamshell mode, you had to press a key or click a mouse button after that
  • If you then opened the lid, the internal display didn't turn back on

You can restore the old behavior by changing the boot-args firmware variable:

sudo nvram boot-args=iog=0x0

You have to restart to apply changes. To undo it, run sudo nvram -d boot-args and restart.

1

I had this issue too, and came up with this script that monitors your lid state and puts the machine to sleep when lid is closed: https://github.com/pirj/noclamshell

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .