3

On an iMac 10,1 running Mac OS X 10.6.8, Finder crashes on every startup.

Safe Boot does not work around the problem.

When I log in normally, the Finder Crashed error messages always steal focus. I can barely access anything else, but I created a new user, and it still does it for that new user. I also disabled all startup items, this does not help.

The crash reports – example at http://pastebin.com/HfJH9gHH – seem very cryptic. As per a conversation in Root Access, the following file does exist (found in single user mode):

/System/Library/PrivateFrameworks/Backup.framework/Versions/A/Backup

I tried Disk Utility from a USB drive (I created based on the 10.6.3 image), and Repaired Disk Permissions, and Verify Disk shows no errors.

What can I try next?


Extracts from the report at http://pastebin.com/HfJH9gHH (the full report is too long to paste here):

Process:         Finder [767]
Path:            /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
Identifier:      Finder
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [121]

Date/Time:       2013-05-04 11:45:05.442 -0700
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          -18769895 sec
Crashes Since Last Report:           319926
Per-App Interval Since Last Report:  -1661176241 sec
Per-App Crashes Since Last Report:   319929
Anonymous UUID:                      1B8A0C6A-8AFD-4016-88FA-E8A1EB1F61C0

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Symbol not found: _kBackupBrowseOtherDisks
  Referenced from: /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
  Expected in: /System/Library/PrivateFrameworks/Backup.framework/Versions/A/Backup
 in /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder

Model: iMac10,1, BootROM IM101.00CC.B00, 2 processors, Intel Core 2 Duo, 3.06 GHz, 4 GB, SMC 1.52f9
Graphics: NVIDIA GeForce 9400, NVIDIA GeForce 9400, PCI, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x8F), Atheros 9280: 2.1.14.6
Bluetooth: Version 2.4.5f3, 2 service, 19 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: Hitachi HDT721050SLA360, 465.76 GB
Serial ATA Device: HL-DT-ST DVDRW  GA11N
USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8502, 0x24400000 / 2
USB Device: Internal Memory Card Reader, 0x05ac  (Apple Inc.), 0x8403, 0x26500000 / 3
USB Device: DT 100 G2, 0x0930  (Toshiba Corporation), 0x6545, 0x26200000 / 2
USB Device: Hub, 0x0409  (NEC Corporation), 0x55ab, 0x06400000 / 3
USB Device: Microsoft 5-Button Mouse with IntelliEye(TM), 0x045e  (Microsoft Corporation), 0x0039, 0x06420000 / 5
USB Device: M2452, 0x05ac  (Apple Inc.), 0x0201, 0x06410000 / 4
USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000 / 2
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8215, 0x06110000 / 6
USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0x04500000 / 2
  • Could you just upgrade to 10.8? Upgrade installs often fix issues like this. – Lri May 5 '13 at 9:35
  • No I can't. It's not my machine, and I can't do anything worthwhile on the gui since the error message keeps popping to the foreground – Canadian Luke May 5 '13 at 15:45
  • You could try moving /System/Library/LaunchAgents/com.apple.Finder.plist somewhere else in single user mode. – Lri May 5 '13 at 17:44
  • @lauri I will try that tomorrow and report back – Canadian Luke May 5 '13 at 18:54
  • @LauriRanta OK, I tried that, and now the system loads, but Finder can't open (error -10810) – Canadian Luke May 6 '13 at 17:22
1

Observations

The file is found, but a symbol is not found.

I sought information after the discussion in Ask Different Chat but found nothing conclusive. As the operating system misbehaviour is extraordinarily bad – both (a) for a new user and (b) in safe mode – I suspect a corrupt installation.

As you also found a problem with archive and install without Apple's DVD, I wonder whether something troublesome has been done with 10.6.8 files that are hardware-specific and not good for the iMac10,1.

Advice

Reinstall the operating system.

You don't have a DVD for installation, but your customer might obtain a replacement disc from Apple; or you or your customer can purchase the missing disc.

Prior to reinstallation

Backup to separate media.

Disk Utility can check the HFS Plus file system structure of a volume, but not media, so you might like to verify media before backup and installation.

  • The above did not fix it, but the reinstall from scratch kinda did. Had to wipe the partition table completely and re-create before the install would let me select the partition. System runs super slow, but it runs properly otherwise – Canadian Luke May 7 '13 at 20:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .