1

I have a MacBook Pro mid 2009 computer. Connecting my usb flash stick doesn't do anything, I tried both ports but not working. I tried connecting an iPad, the iPad charges but it doesn't open show in iTunes for syncing.

One thing to note is that Windows on VMWare recognized the devices when it is active, but not MacOSX. That means the problem is not hardware related.

1

Have you repaired disk permissions and reset your PRAM?

Follow these instructions to repair disk permissions: http://support.apple.com/kb/ht1452

Follow these instructions to reset PRAM: http://support.apple.com/kb/ht1379

  • I followed your instructions to repair disk permissions and reset PRAM. Still no luck :( – user3885 Feb 25 '11 at 11:49
0

Go to the Apple menu and choose About This Mac. Click the More Info button. In the new window that appears, click USB under Hardware on the left. Expand the items there. Do you see your flash drive or iPod?

If not, you've probably got a hardware problem. Take it to the Apple Store if you've still got a warranty.

  • I can see my flash drive and iPad on the System Profiler, no problem with that. – user3885 Feb 25 '11 at 11:48
0

I had this happen to me this morning as I was trying to debug some iPhone code on a device. It wouldn't see my phone, a flash drive, or anything I plugged into USB. Finally, with my fingers crossed, I rebooted - when it came back up all was well.

  • I rebooted several times, still not working. – user3885 Feb 25 '11 at 11:48
  • just wanted to comment that i had the same problem and by rebooting ... the problem was gone... – Mamonu Dec 15 '13 at 18:28
0

You said that you have rebooted several times, but sometimes rebooting isn't enough. Did you try powering down the Mac completely, then starting it up? That is often a cure for odd problems like these when nothing else works.

0

There may be a preference on VMWare that it allowing the devices to go to Windows instead of Mac - I know Parallels has that. Try looking for and deactivating device preferences.

0

I had a similar problem. Resetting the PRAM solved it.

You must log in to answer this question.

protected by bmike Mar 11 '17 at 20:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?