6

I'm typing on my Retina MacBook Pro, and the response rate on the keyboard is terrible. It's like typing on an LCII that is trying to run Mac OS X. As I type, the computer seems to be thinking ridiculously hard about what it is doing. Periodically, these silly character suggestions will appear next to the cursor:

The response rate is so bad that I am literally typing this message one painstaking character at a time, and waiting for it to appear on the screen before typing the next. I estimate < 20 WPM. Keys are randomly repeating as well.

Any idea what this is or why it is happening? This is the second time I've had this issue. I haven't been able to find any info in the Apple forums about it, I'm guessing because I don't know what this phenomenon is called.

5

The characters appear when a key is held down, it's the same as on an iPhone to make it easier to type accents and things. Those are alternative S characters.

You can turn it off using:

defaults write -g ApplePressAndHoldEnabled -bool true

in Terminal.

However, that doesn't explain the overall response rate, just the characters.

For the keyboard rate check Accessibility in System Prefs. You might have Slow Keys enabled in the Keyboard section. You might also want to check under options at the Acceptable Delay in that panel.

  • Thanks @Alex. So, what is happening is that the keyboard input is SO laggy, that it is causing the character helper thingy to appear now and then (pretty randomly), just like it is randomly repeating characters. You're also correct in that it does not explain the slow input rate. I checked "SlowKeys", and tried enabling/disabling, but that didn't reproduce the behavior. – user48598 May 2 '13 at 23:20
  • 3
    I would +1 but stackexchange is lame and won't let me. – user48598 May 2 '13 at 23:22
  • @user48598 I've up voted your comment since you still lack the reputation to up vote here. It won't be long if you keep asking good questions that you'll be able to chat and comment and use the site as a trusted user. – bmike May 4 '13 at 18:52
  • Related: to set a [blazingly fast keyboard repeat rate](mths.be/osx), use defaults write NSGlobalDomain KeyRepeat -int 0 and reboot. This probably doesn’t help in your situation, though. – Mathias Bynens May 10 '13 at 7:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .