I just got an iPhone 4 and downloaded the most recent version of iTunes onto my computer because I had a version that was too old. It told me I needed to convert the songs to create an AAC version of my library in order to sync them to my iPhone, which I had not synced because I didn't want to lose the existing music. When I converted the files, they copied to the phone, but are greyed out and won't let me play them, could somebody please help?

8 Answers 8


Try playing the greyed out songs directly on your iPhone. If you cannot do that, do the following.

  1. Ensure that the greyed out songs are indeed playable within your iTunes library (not within the iPhone section of your iTunes library)

  2. Connect your iPhone to your iTunes, navigate to your iPhone section > music, select all greyed out songs and delete them.

  3. Make sure that the "Sync music" and "Entire music library" options are ticked under the "Music" tab and sync your iphone once again with iTunes.

This should resolve the issue.

  • thanks a million! but if I click the sync option will it delete all the existing songs on my phone?
    – user48569
    May 2, 2013 at 17:47
  • depends. If all of your iphone songs are already loaded within your iTunes library on your PC, then there is no danger of deletion. If you need to transfer songs from your iphone to iTunes, make sure to read this: copytrans.net/support/gettingstarted-copytrans/smart-backup
    – jDonMas
    Jun 18, 2013 at 14:47

I made a playlist, copied and pasted the songs from the old one, and deleted the old one. I re-synced the phone and it worked. It worked for all of them just by recreating one.

This solution fixed the grey circles next to 60% of my songs. I planned to make all new playlists but started with one as a test.

I chose a playlist where I had just purchased a new song today. Perhaps that caused a jam somewhere. Hope this helps someone.


I solved this issue by selecting a song (or songs, one whole album), right-clicking, and selecting "Uncheck" selection. Then did the same to "Check" selection and it began syncing ("un-greying") all of the songs in my library that were stuck like that.


I hope anyway who has this 'kind' of problem, greyed out songs. And they like to delete them forever. then continue reading

I don't want to advertise programs but I think it solves it quickly , and yes it really did work for me. I was really fed up using itunes and having those unsynced music. Programm is called 'Copytransmanager. (google it up, read reviews and you'll see!)

With this programm i easily deleted all the greyed out songs, unlike using itunes which I stucked on over 3 weeks. Of course there are plenty other programms to do this, but I read a lot on other forums etc people got this problem. So I'm just post here quickly to help!

I think once you've downloaded it, it's easy to find out how it works. (simple design, though it's not as clear as itunes.

Greetings and I hope a few could use this information. Once again, I do not like to promote/advertise other programs but sync/resync doesn't seem to solve for some.

*Also if you like to keep those 'greyed' tracks, they: make a backup somewhere and you can put them back on with itunes or just CopyTrans again.


I had this same problem: After dragging songs from library to phone, I looked at the music on my phone (from the iTunes' PC interface) and saw the songs listed but "greyed-out".


I clicked on Music underneath My iPhone on the sidebar. On the bottom right of the screen there is a button called Autofill located next to a button called Settings. I clicked the Autofill button, and it said that I could not add any more music because all of the space was reserved for data. If you get that message when following the steps above, try this:

In that same tab, to the left of Autofill on the right, click Settings. There is a slider located at the bottom of the dialogue box that pops up which allows you to define how much space is reserved for data (non-music data.) If that slider is all the way to the right, you will not be able to add any songs to the iPhone manually. Slide the bar to the left to allow for more space for music, the try adding your songs. Worked for me.


If you drag the music from your ITUNES LIBRARY to the Iphone (drag it towards the right side of the screen where it says Iphone), then it will no longer be greyed out!!! :) And it will not sync anything.


Just fixed this problem on my iPhone 4S. Simply select all greyed out songs (Edit -> Select All) drag them to trash and voila - you can start dragging and dropping music from your library.


Simple fix for me.....I found that it was the format of the songs. I made an mp3 copy in my tunes of the purchased songs, and they showed up with normal text. I was then able to copy the purchased songs to my devices. Go to File, Convert and change formats as needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .