I am trying to share an ethernet connection on a MacBook over Wi-Fi. I enabled Internet Sharing in the Sharing prefpane,

Internet sharing enabled

When I try to connect using an iPad, the iPad can see the network but cannot join. No error message is displayed if the network is unsecured, and if the network is secured, the iPad displays the error message 'Unable to join the network, "[network name]"'.

I have tried:

  • Rebooting the MacBook
  • Turning the connection on and off
  • Resetting the network settings on the iPad
  • Changing the IP address of the Wi-Fi on the Mac from the "self-assigned" address to
  • Deleting /Library/Preferences/SystemConfiguration/com.apple.nat.plist (suggested in this AD question
  • Deleting, as suggested in this AD question:

  • Doing, as suggested in this AD question,

    $ sudo ifconfig en0 down
    $ sudo ifconfig en0 up

What should I try next?


1 Answer 1


I fixed it! What wound up working for me was going to the Network prefpane, deleting the Ethernet and Wi-Fi interfaces, and re-creating them.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .