14

How can I prevent my Macbook from connecting to non-secure wireless networks?

I've ticked the "Ask to join new networks" option and removed the offending network from the Preferred Networks list in Advanced > Wi-Fi.

Ideally, I'd like to blacklist a particular network based on its name (rather than on any HW addresses, since there are many access points with this name).

My system: Mac OS 10.8.3, Macbook Air 13", mid-2011.

  • What exactly do you mean by non-secure wireless network? – dan May 9 '13 at 14:50
  • By non-secure, I mean an "Open" network which does not challenge new clients to authenticate. Like you find at cafes etc. – RobM May 12 '13 at 16:11
15

Your Mac will only automatically join Wi-Fi networks which are in its preferred networks list.

If the non-secure network is not in that list, it will not join it.

If you want to be prompted to join a network when no "known" network is available, turn on "Ask to join new networks."

However, if you do not turn on "Ask to join new networks" then your Mac will not automatically join the non-secure networks, it will simply stay disconnected without prompting you.

So there is no need to 'blacklist' a network because it will not join it unless you tell it to join it. Unfortunately there is also no way to tell your MacBook not to present it as an option. The best you can do is require an administrator password before it can be joined:

Wi-Fi System Preferences

  • 1
    Now let's say you entered a trusted MacDo Wi-Fi wireless network because this one is trusted. Now this name is included within your Wi-Fi whitelist. What will happen when you arrive to another place where there is the same wireless network name MacDo Wi-Fi but this time this is a totally unsecure wireless network (the admin password of the wireless router is publicly known and under control of a bad guy on the other side of the street ☹)? – dan May 9 '13 at 14:49
  • It won't join it. I've had this exact situation before when I changed my home network. I kept the same SSID, but removed the password. My Mac would not join it automatically. I could join it manually. However, until I removed the password from my Keychain, it would not join automatically. You can easily test this yourself if you have a Wi-Fi router. – TJ Luoma May 10 '13 at 7:30
  • Automatic connection failed on your 2nd wireless network because of a failed authentication. I suggest you to test 2 networks with the same name and the same authentication. Mind that a real trap will be built this way: don't frighten the prey. – dan May 10 '13 at 8:05
  • 2
    OK, I tested it. I created another Wi-Fi network using the same SSID and password as my current network. I turned off Wi-Fi on my Mac, and then turned off my router, leaving only the new Wi-Fi network with the same name. I turned Wi-Fi back on. My Mac did not join the trojan network automatically. In fact, I couldn't join it manually. The only way to join it was to go in, delete the SSID from my known networks, and re-add it. Even if I did that, it's not clear to me what this "trap" would accomplish. If you're that worried about it, get a VPN. – TJ Luoma May 10 '13 at 16:41

You must log in to answer this question.

protected by Community Nov 29 '16 at 18:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .