0

A program i run cannot find a specific file. The file is right there where it is supposed to be. When i use Finder to locate it:

  • it is found if i tell it to look in ~/Library
  • it cannot be found when i tell it to look in 'This Mac'

Surely ~/Library is on 'This Mac', so everything in it is also on 'This Mac'?

It is not a matter of user rights, the file cannot be found looking in /Users/myname. I have used chmod to set the rights: -rwxr-xr-x Other files of this type, at the same location are found without a problem. Is there some invisible OSX setting i am missing?

The program is latex, the file is a .bst file, located in its own directory in the ~/Libraray/texmf/tex/latex/ directory. I'm still running OSX 10.5.8.

  • How does it run and how does it try to use the file? – user151019 Apr 27 '13 at 22:00
  • I'm not sure latex actually needs to execute .bst files, read-permissions may suffice. I dont understand your first question. – Ivana Apr 27 '13 at 22:40
  • What is the command line you run? – user151019 Apr 28 '13 at 8:57
  • @Mark, i run TexMaker, which is an app. I dont know the specifics of how the underlying latex searches for .bst files. I know where it looks: ~/Libraray/texmf/tex/latex/ – Ivana May 1 '13 at 9:13
2

Spotlight is intended to let users find their own files; since the Library folder normally contains files the user doesn't need to (and indeed shouldn't) access manually, it's left out of the search results (along with other "system files"). You can find files in it by either searching it explicitly (as you mention), or by telling spotlight to include system files in its results (see Apple's KB article #HT4355 -- note that it only mentions OS X 10.6, but the same procedure works in 10.7 and 10.8 as well).

  • That does not explain why the file is found in ~/Library but not in ~/. And its not really a Spotlight problem because other programs cannot find it either. – Ivana May 1 '13 at 9:10
  • Sorry, it does explain why it is not found! But not why other, adjecant files of the same type are found but not this one file. – Ivana May 1 '13 at 9:27
  • Is it finding other files in ~/Library when you search ~? If so, I have no idea why it would do that, as it's supposed to leave ~/Library out of the results. – Gordon Davisson May 1 '13 at 14:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .