I have a friend with a 13" MacBook Air. He upgraded to the new software in the App Store about a week ago and now, when he is using anything that uses his built-in camera, it says "There is no connected camera." I've tried looking through his settings and nothing is working to fix the problem. I've found a number of problems, but nothing has worked. We're not sure how to go about solving the problem, even after finding several solutions to no avail. Anything helps, thanks!

  • 2
    Can you help us a bit here by clarifying which upgrade (of which software) are you refering to here and which specific fixes you have already tried (so people know what not to propose any more). A typical recommendation at this point would also be to create a new user on the Mac and see whether the camera works for the new user.
    – nohillside
    Commented Apr 26, 2013 at 6:19
  • I apologize for my ineptitude on this part, but the most recent one as of today. I will try that.
    – Throsby
    Commented Apr 26, 2013 at 14:00
  • 1
    No reason to apologize really, it's just that our crystal balls usually work better the more details are already known :-)
    – nohillside
    Commented Apr 26, 2013 at 15:01
  • I have the same problem - the 'new software' was Mavericks, and my camera hasn't worked since. I've killed VDCAssistant, reset the SMC and PRAM, and copied good versions of the AppleCamera DAL and FCP-DAL plugins and kexts from a laptop with a working camera. Nothing works.
    – Simon
    Commented Aug 27, 2015 at 10:27

3 Answers 3


Probably there is some process holding the camera. A dirty hack to solve this issue is to kill the culprit with:

sudo killall VDCAssistant

I had this problem occasionally too on the same model. A temporary solution was to do a SMC reset and a PRAM reset. You can find the instructions here, or below.

The reason why sudo killall VDCAssistant didn't work for me was that the camera had disappeared completely from the system. It didn't show up in System Report under camera.

A while ago I noticed uneven backlighting on my MBA and had the display changed under warranty. It seems that this fixed the camera problem also, so you may want to take your MBA for a checkup to AppleCare.


  • Shut down the computer.
  • Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
  • On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.
  • Release all the keys and the power button at the same time.
  • Press the power button to turn on the computer.


  • Shut down the computer.
  • Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step
  • Turn on the computer.
  • Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
  • Hold the keys down until the computer restarts and you hear the startup sound for the second time.
  • Release the keys.

I tried the terminal command and it didnt work and I also got the “no matching processes found.”

I finally got it to work, here’s how.. Most likely, you probably have a third-party app blocking the camera. In my case, it was the Kaspersky Anti-Virus thing. If you go to your anti-virus app > Preferences > Privacy > Stop blocking webcam… it should work. The reason this happen is because blocking the camera protects you from hackers hacking into your camera.

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .