5

I have an issue with the USB ports on my Macbook Pro. When I plug a device in, the device draws the power, but nothing else happen. This is what I know about this problem:

1- USB Prober can see the connected devices and identify them
2- VMFusion it's able to connect the device into the guest OS but nothing happens
3- If I reboot in windows all works good (no HW fault)
4- I tried to reboot in safe mode, login, reboot
5- I tried to reset SMC, nothing.

Later on I realized that apparently this issue it's related only to the composite devices, a simple USB disk work. An iPhone, iPod or Broadband Modem will not work.

Any idea ?

5
  • Are you using a USB hub?
    – Harv
    Feb 23 '11 at 3:41
  • Harv: no hub, and until... don't know when i never got this issue :(
    – Cesar
    Feb 23 '11 at 4:20
  • Which macbook pro do you have? Can you try with another USB port? Same behaviour?
    – Nivas
    Feb 23 '11 at 5:46
  • 1
    Have you tried it with another user account on your machine? If it works there, it's user-account related. Feb 23 '11 at 10:47
  • 1
    The system profiler will enumerate all devices on the USB buses and crawl hubs too. If it's showing there - it's a driver / vmware issue (vmware can hide devices from the mac software so that it goes untouched to the virtual machines - make sure it isn't hiding your devices)
    – bmike
    Jul 23 '11 at 16:33
1

Well - if the port works, and you can plug in multiple other devices into the port it sure looks like the problem lies in the composite device and not the mac.

The only way to know if that type of device is broken or is just not compatible (and the mac is shutting it off immediately on detection to protect itself) is to take that device to another mac of the similar hardware and test.

Experience would say just that device is broken - but you'll have to test to know for sure.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .