1

Strange Moment !!!

I was testing my iPhone App on iPhone 5.1 Simulator. App ran very fine. But got strange situation at the time of removing App from Simulator. I followed these steps to remove the App from Simulator :

1) Long Press on App Icon.

2) Step-1 resulted in this Situation. (that's usual) :

enter image description here

Problem :

When Clicked on that "X" mark , to remove the App , I didn't get Alert (usually with title "Delete yourApp" , Description "Deleting yourApp will also delete all of its data" and two Buttons of "Delete" and "Cancel").

The Screen got hanged. I tried several times but same Result.

Why this happens and what to do to solve the Problem ?

Note : I have tried to Reset it but Resetting the Simulator removes all the Apps from the Simulator. I am curious to find some way to remove that single App from Simulator.

  • 1
    Also got the same problem with Springboard hanging, requiring me to force quit the simulator. – bouke Apr 25 '13 at 12:05
  • 1
    I've actually had this happen on regular iOS on my iPhone 5, so it might not always be simulator related – Josh Hunt Apr 29 '13 at 10:59
2

Go to the iOS simulator menu and choose Reset Content and Settings...

enter image description here

Why this happens is harder, but it's just development and you are working with a simulator, not a real device. Sometimes it's faster to get out the broom and clean the floor to start freshly.

If you are curious, the simulator filesystem is stored in the following location:

~/Library/Application Support/iPhone Simulator/version

So if you want to poke around and delete things, you could try to exercise the phantom app, but I don't see you saving time by somehow editing the filesystem and hoping the simulator would work once it's broken in the manner you describe. The normal way to delete an app is to press the X and since that's broken, who knows what else is out of sync. Better to start fresh and not waste more time when the system says there is a problem with the simulator.

  • yeah, that i tried before. But it removes all the Apps. I want to delete that particular App only. – Bhavin Apr 24 '13 at 14:41
  • 1
    The problem is the system being simulated is messed up. It's not that app you want to delete, but the springboard data and other filesystem items are no longer coherent. When the normal mechanism for cleaning up one app (pressing the X) fails, you need to start over and push both apps to the simulator in the manner you did to get them there in the first place (which could be the root of the issue). – bmike Apr 24 '13 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .