Since I upgraded to Lion (10.7.5), Finder doesn't display thumbnail previews of ARW files. ARW is a Sony RAW image format (in my case files were produced by Sony NEX-5 camera). Finder used to display the thumbnails under Snow Leopard (10.6.8), but not anymore. ARW files are opened as usual by the Preview app, their previews are shown in the Finder preview column and by Quick Look. Only the thumbnails are not shown.

I've googled and found this is a well-known issue but unfortunately there is no reliable solution. Somebody fixed it by removing Finder preferences files (~/Library/Preferences/com.apple.finder.*), somebody by installing latest versions of iPhoto and "RAW Compatibility Update" and somebody reported it was only fixed for him in ML 10.8.2 update.

So far I have:

  1. Fixed the permissions on system drive
  2. Removed Finder preferences files and restarted the Finder
  3. Installed updates for iPhoto (9.4.3) and RAW Compatibility Update (4.05)
  4. Danced with a shaman's tambourine

But still no luck. Any thoughts? Is upgrade to Moutain Lion my only choice? And will it indeed help?

  • A couple of comments. RAW camera support is something that does change incrementally - so you might want to add the exact versions of software by editing your question. (e.g. I upgraded from 10.6.8 to 10.7.2 and have iPhoto version Y installed). I'll take a stab at pointing you to resources, but without more detail we can help you troubleshoot this and perhaps not solve it.
    – bmike
    Commented Apr 24, 2013 at 12:41
  • @bmike I've added versions info to my question. To summarize: I upgraded OS X from 10.6.8 to 10.7.5 and have iPhoto 9.4.3 installed. I also installed RAW Compatibility Update 4.05
    – Volo
    Commented Apr 25, 2013 at 11:43

2 Answers 2


Raw support for cameras is something that changes with almost every OS update. Specifically, Lion 10.7.0 only supports some cameras, and 10.7.1 adds more, and so on. Also, according to this KB article on what cameras Apple supports - it is similarly vague that you need specific versions of Aperture or iPhoto to even see whether your machine needs a RAW camera support update.

So, it looks like Apple is adding raw support to the OS in combination with you having a new enough version of either iPhoto or Aperture. I would say, you might want so jump to 10.8.3 and install the latest iPhoto from the Mac App store since my feeling is Lion intentionally changed RAW processing to exclude anything it wasn't sure it supported instead of 10.6's we'll try to draw anything and if it crashes, so be it attitude.

However, if you don't want to spend $40 on this, delay the upgrade to Mountain Lion and just buy the latest iPhoto (if needed). At that point you can call Apple support since you recently purchased iPhoto (or possible recently purchased Lion) and ask AppleCare to verify your camera model is compatible with your software versions. You get 90 days of complimentary software support anytime you purchase Apple hardware or software since they want you to get up and running with your new purchase.


I've managed to fix it. Here is the story.

After I upgraded iPhoto to 9.4.3 and restarted the Finder, it started to display ARW thumbnails. Sometimes... But sometimes black icons were shown again instead of image thumbnails and previously rendered thumbs disappeared as well.
I manually removed the thumbnails cache (on my system it was stored in the folder
/private/var/folders/XX/YYYYYYYY/Z/com.apple.QuickLook.thumbnailcache/) and restarted the system. It helped, but only till the next time my MacBook had gone to sleep.

Then I found the nice article on fixing Quick Look issues and runned the following commands:

qlmanage -r
qlmanage -r cache

After that I relaunched Finder and the issue seems to be gone now.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .