Suddenly, a couple of days ago, I have started to have major problems accessing internet through my home network, with my MacBook Pro Mid 2012 (non-retina) running Mountain Lion.

I connect to the network just fine, but when can't open web pages or when I try to ping google.com I get:

ping: cannot resolve google.com: Unknown host

or something like:

PING google.com ( 56 data bytes
Request timeout for icmp_seq 0
64 bytes from icmp_seq=1 ttl=53 time=43.372 ms
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
64 bytes from icmp_seq=5 ttl=53 time=45.110 ms

--- google.com ping statistics ---
6 packets transmitted, 2 packets received, 66.7% packet loss
round-trip min/avg/max/stddev = 43.372/44.241/45.110/0.869 ms

I can't find any pattern to the results.

ALL other devices on the router has no problem access neither the network or internet. Of these are another MacBook Pro, an iPad, several iPhones, Apple TV, and misc.

The network is set up to configure IPv4 with DHCP and IPv6 automatically. (Under General > Network Wi-Fi > Advanced > TCP/IP)

I have tried flushing the DNS with both: (https://gist.github.com/mipmip/1844353)

sudo killall -INFO mDNSResponder
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

I have tried removing and adding the Wi-Fi interface from General > Network.

And of course I have tried rebooting the modem, router and computer.

What else should I do to get internet working again?

4 Answers 4

  1. Delete the following 3 files located in ~Library > Preferences > SystemConfiguration :

  2. Delete the airport / wifi network interface and re-create.

  3. Reboot and connect to WiFi

  • Do you mean /Library/Preferences/SystemConfiguration? Because the is do not have a ~/Library/Preferences/SystemConfiguration.
    – mfaerevaag
    Apr 23, 2013 at 18:12
  • That would be it.
    – KWhitt
    May 13, 2013 at 17:43

I'd run /System/Library/CoreServices/Network Diagnostics and see if the report can pinpoint if there is a problem with the configuration or the network devices that connect you to the internet.

The failure to resolve a common DNS and packet loss makes it look like a very lossy network, but that's harder to fix directly than a configuration issue.

If you took that Mac to another network and test, you might be able to rule out any hardware issue on the Mac as a likely cause.


nIssue fixed. Network Diagnostics saved the day.

Fortunately, my other computers on the network were okay, so I was able to find this article!!

I had this issue all day. Everything was fine last night. This am, after opening the laptop ( 2013 15" retina )- I had the issue. I could connect to the network, but not get online. Tried turning off IP6 and other things ( bouncing router, etc). But running Network Diagnostics somehow fixed it for me. No idea why. The settings I used were the same as they were before.


EDIT: This initially work, but after a couple hours I'm back where I started.

Fixed it! I found this which helped me: No internet access on MacBook Air, though I can connect to networks

Apparently my mDNSResponder daemon was corrupt. To fix:

I copied com.apple.mDNSResponder.plist and com.apple.mDNSResponderHelper.plist in /System/Library/LaunchDaemons/ from a MacBook Pro which could already acces the web.

I set the correct owner and persmisisons:

sudo chown root:wheel com.apple.mDNSResponder*
sudo chmod 644 com.apple.mDNSResponder*

Like this:

-rw-r--r--  1 root  wheel  1109 Apr 23 14:40 /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
-rw-r--r--  1 root  wheel  1035 Apr 23 14:38 /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist.backup
  • Did the files get corrupted again?
    – nohillside
    Apr 23, 2013 at 21:12
  • I've tried doing the same, but no luck this time so I guess not. Might have been coincidental that it helped the first time, who knows.
    – mfaerevaag
    Apr 24, 2013 at 7:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .