0

Since a while now, I can't use the app store anymore on my MacOS Lion. It just keeps the screen "One Moment Please. Connecting to the iTunes Store.".

I tried a couple of things ... rebootet ... waitet for days and tried it again ... cleared the cache, as described here: Mountain Lion Doesn't Download from Store and some more stuff.

Nothing shows up in the Console.app ... iTunes works just fine ...

The only thing that's curiouse is, that if I click on the link "To download iTunes, please click here.", the page shown is in swedish ... I've never chosen that as language on this system.

EDIT: The login doesn't work. The credentials are correct, because I can log in at apples developers area and download stuff like xcode from there.

  • Just how do you get to apple developer without logging in to apple store? – Ruskes Apr 23 '13 at 9:50
  • @Buscar웃 Logging in at developer.apple.com/devcenter/mac/index.action just works. But it does not work if I try it using the AppStore. – SimonSimCity Apr 23 '13 at 11:02
  • Did you try to log out from apple store. – Ruskes Apr 23 '13 at 11:35
  • @Buscar웃 How can I signout? Or turn the question around: Is it possible to sign in if you are already? I just see the "Sign In ..." and "Create Account" actions in the menu. – SimonSimCity Apr 23 '13 at 16:12
1

EDIT: Since you made your edit my answer is not valid.

In Apple store click on Store + View my Account

Sign in.

Bottom right just below the DONE click on the globe flag icon, and change to your country.

enter image description here

  • The signin doesn't work as well ... no logging here either ... – SimonSimCity Apr 23 '13 at 9:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .