I'm running OSX 10.7 and following the instructions linked below am failing to start hidden services.

enter image description here

I keep getting this error: "Error creating directory ...". It's either No such file or directory (you bet ya there is) or it's "Permission Denied," if I try to put them where the the tutorial suggests

On windows C:/hidden_service seemed to do the trick just fine. I've tried moving it around, tried it with and without the ~ (such as ~/Documents etc). It can't seem to find the folders. I first tried moving it to Applications (which shouldn't matter if you run it as super user right?) but it didn't work. It just doesn't seem to "see" any folders

I've launched the Vidalia app as superuser, chmodded all folders and files to 777...

The way I understand the instructions, Vidalia will CREATE the /hidden_service/ folder for you. I've tried it with both being there and not - same result.

What is happening and can someone point to a solution?

PS: As a clarification, it will place files there identifying the hidden service address and some miscellaneous connection data. The issue appears to be Vidalia's inability to access the filesystem (unless the permission is denied, then it can suddenly "see" it)

  • 1
    What exactly is your question? "How do I install Tor" or "Why can't Tor create this folder" or something else? Let's see if anyone has a ready answer. If not, we can help you edit your question to provide more details on what you've tried and what exactly doesn't work. See the guides on tour and How to Ask if you don't get an answer and decide to edit your question. They are often helpful in refining / reframing your query. – nohillside Apr 21 '13 at 12:29
  • Did you use the checksum checker to verify your installation. support.apple.com/kb/ht1652 – Ruskes Apr 21 '13 at 13:40
  • 1
    Patrick's comment is spot on and I would say, you might answer the question yourself with the steps you took to "run it as super user" since even a wrong answer points to others what doesn't work. If you added all the steps to the question, it might become so long that others don't step in to answer it. The comments on your "how I made it run as super user" would be useful to others and might get us all to the real answer since it's likely a sandbox / permissions issue of some sort. – bmike Apr 21 '13 at 15:50
  • Pardon fellers, let me rename the question for clarity. – dsp_099 Apr 22 '13 at 0:29

You must log in to answer this question.

Browse other questions tagged .