2

I use GIMP a lot for my work, especially for modifying figures in EPS format to put in my latex documents. However I don't know how to configure GIMP to open EPS files. In fact if I try to open an EPS it says that the format is not recognizable. On the contrary under linux that is automatic? How it can be possible?

I'm using Mountain Lion with GIMP 2.

Appreciate any help, thanks.

3

If I understand this bug report (https://bugzilla.gnome.org/show_bug.cgi?id=689657) correctly, you can check if your version of Gimp supports ps and eps (it may not, even if you have ghostscript) by doing the following:

Open Gimp. In the menu, click help, and then procedure browser. In the procedure browser search for 'file-ps-load'. If it's not listed, Gimp won't open ps or eps files.

My version of Gimp doesn't have this. But I haven't tried downloading the current version, maybe the current version has this enabled.

It's not too hard these days to set up Linux in VirtualBox. If you have no other alternatives available and don't want to buy Windows or another computer, you can use Gimp on Linux (probably Ubuntu) in VirtualBox.

3

I have no explanation but you can use Partha.com's distribution to open .eps (download link to be added when more reputation) instead of the general distribution.

Source: ofnuts'answer on gimpforum.com. Working in OS X 10.11.

Edit: to make it stand alone

  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. – nohillside Oct 23 '15 at 7:19
  • While understanding both of your remarks, I do not see what "essential part" of my answer could be included here: my answer is simply "get this other distribution", which while being poor and unstable, works. – Loïs Boullu Nov 6 '15 at 16:07
  • This worked for me. :-) – Ellen Spertus Sep 27 '17 at 20:20
0

Gimp normally "opens" an EPS file by rasterizing it first, normally through GhostScript. If you don't have ghost script installed, this may be failing or there might not be an eps plugin installed on your copy of the Mac OS X version of Gimp.

Once you have GhostScript installed, you just need to make sure that Gimp can see the 'gs' binary so that it can rasterize the EPS files.

  • How do you make Gimp see the gs binary? I tried putting an LSEnvironment value in /Applications/GIMP.app/Contents/Info.plist as described here (developer.apple.com/library/mac/documentation/MacOSX/Conceptual/…) like this <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>LSEnvironment</key> <string>GS_PROG=/usr/local/Cellar/ghostscript/9.07/bin/gs</string> <key>CFB... – David Winiecki Jan 12 '14 at 1:01
  • But that didn't work. I also tried doing this in Terminal, but it didn't work either: $ GS_PROG=/usr/local/Cellar/ghostscript/9.07/bin/gs; open /Applications/GIMP.app/ – David Winiecki Jan 12 '14 at 1:03
  • 3
    From the gimp website: gimp.org/downloads There are 2 versions of Gimp available for download for the Mac OS X environment. One stock and one with plugins. The one with plugins, links to: gimp.lisanet.de/Website/Download.html On my system, I also have installed 'ghostscript' via homebrew. I've not needed to modify any plist bits. – Wing Tang Wong Jan 23 '14 at 22:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .