2

I am running OSX Mountain Lion 10.8.3 and Safari 6.0.4

In Safari, the setting General -> "Safari opens with" is missing.

I remember using this setting to turn off session restore a few weeks back. But now its gone.

Type "Safari opens with" in google and "missing" is autosuggested. So I am not the only one with this problem. However, I didn't find any good pages/posts talking about this issue.

Can any one offer ideas on how fix this?

Edit:

To clarify, its not that some of the options in the setting are missing, but that I don't have the setting for "Safari opens with" at all. I have the setting Default search engine and below that directly New windows open with, without Safari opens with in between.

  • what is your safari version? – Ruskes Apr 17 '13 at 17:35
  • Opens with: (New Window) or (All windows from previous session) are the only choices. – Ruskes Apr 17 '13 at 17:37
  • I have Version 6.0.3 (8536.28.10) – Ruskes Apr 17 '13 at 17:41
  • I have Safari 6.0.4. However, I am not talking about the choices. The whole setting itself is missing. To repeat, I don't have the setting for "Safari opens with" at all! – Himanshu P Apr 17 '13 at 18:35
  • ups :). ok just to say, it works on mine, so let me see if I can make it not work. – Ruskes Apr 17 '13 at 18:38
2

That option has been removed from recent versions of Safari.

I'm not aware of which exact build removed it, but I can confirm it is gone and should be gone on all clean installs of Safari on top of OS X 10.8.3 and later. After running all available updates as of May 1 - you should have Safari version 6.0.4 (8536.29.13) and no Safari opens with preference.

Unless you have a defaults write… terminal command to re-enable that setting as a , spending time troubleshooting this would be inadvisable since the control you are looking for is gone for now.

2

I had this problem today on one Mac but not the other, both same version of Safari. Fixed by:

  • System Preferences → General → Check 'Close windows when quitting an application'

  • Safari → Reset Safari…

  • Close and reopen Safari

And it magically reappeared!

-1

It looks like you have a corrupt safari plist.

To fix that (plist) do following:

Quit Safari.

Go to ~/Library/Preferences

Move the com.apple.Safari.plist file from the Preferences folder to the Desktop.

Relaunch Safari.

If that helped, move the Desktop .plist file to the Trash.

If not, move it back to the Preferences folder.

enter image description here

  • Tried this, did not help unfortunately. – Himanshu P Apr 17 '13 at 19:16
  • @HimanshuPokhariya Where did you get the Version 6.04 ? – Ruskes Apr 17 '13 at 20:15
  • I didn't do anything myself to get/update Safari really, so it must the through automatic updates. – Himanshu P Apr 18 '13 at 9:47
  • @HimanshuPokhariya To avoid surprise in the future disable Automatic Install in the system preferences software updates. – Ruskes Apr 18 '13 at 10:17
-1

Your problem is coming from the new Safari 6.04.

A version that was premature (in haste) released without proper testing.

Two days after the 6.04 was removed from downloads sites.

Please remove your Safari and reinstall the 6.03 from Apple.

Sorry for that.

  • It's your word against a well-known computer company in Cupertino (support.apple.com/kb/HT5678). – nohillside Apr 17 '13 at 21:56
  • @patrix Not really, and I know about the screw up! Just try to download the 6.04 from the official site. – Common-Courtesy Apr 17 '13 at 22:19
  • @patrix It is a 19kb index.html file ? With some major problems in it as you can see in the OP. – Common-Courtesy Apr 17 '13 at 22:49
  • Let's wait for answers on the Safari question you just asked and get some hard facts on the assumption about the bad release. – nohillside Apr 18 '13 at 8:56
  • @patrix If we want to wait for hard facts, why are you prematurely voting negative? – Common-Courtesy Apr 18 '13 at 9:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .