Up until recently I was using my 2007 MacBook perfectly fine with my old AirPort Express. A few days ago I purchased a used mid-2010 iMac which is now running OS X 10.8.3 (something I'm still not too sure I like). When I first brought the iMac home and connected to my network it did so just fine but the AirPort icon in the menu bar showed there was no internet connection, despite the signal being full. I then followed some step-by-step setup which rebooted the AirPort Express and all of a sudden I had internet! Great! …except since then my MacBook has the same problem my iMad had, i.e., it connects to the network just fine but the network icon shows no internet connection :(

I should mention that my MacBook is running OS X 10.6.8. I'm wondering if this is an OS compatibility issue or… Has anyone experienced something similar?

  • 2
    What do you think is broken? The router or the MacBook? It's not clear to me if the problem is intermittent or persistent and if you've isolated it to one piece of gear yet (from the description)
    – bmike
    Apr 16, 2013 at 18:34
  • The router works, because I'm posting this form the iMac that uses it to connect to the internet. The MacBook worked perfectly fine until the iMac forced me to reset the router so it could work…
    – bernk
    Apr 16, 2013 at 20:58

1 Answer 1


Setting the AirPort Express b/g to g-only mode solved this problem for me, though I don't understand why.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .