43

This thing's driving me crazy.

Often, when I download or create a new file, and then I have to upload it to a website or something like that, it will appear after the oldest items under a "No Date" section.

I'm running Mountain Lion but it happened for me at Lion as well.

Any ideas how to fix this?

Screenshot

  • This happens when the files in question have a "Date Modified" in the future. – duci9y Apr 15 '13 at 14:45
  • OK. Why would this happen? Is this a timezone issue? – yonix Apr 15 '13 at 22:13
  • The file metadata may be corrupt. – duci9y Apr 16 '13 at 8:28
  • 3
    I have only experienced this in Chrome's Open dialog - are you experiencing this as a general issue in Finder or just in Chrome? – Emil Rasmussen Apr 17 '13 at 7:32
  • 1
    @EmilRasmussen currently I can reproduce this only on chrome but I'm pretty sure in the past it happened in general finder windows or other apps' open dialogs as well. – yonix Apr 17 '13 at 11:31
24

I don't know if this is really a "solution" per se, but it's a workaround that I prefer anyway: I changed the "Arrange by" to "None" as described here Mac OS X - File Open Dialog: Can't sort or resize columns

This gets rid of the categorization by Today/7 days/30 days/etc. altogether, and just gives a straightforward dialog that lets you sort however you want (be it Date Modified, or Name, or Size). I find this much more useful and fail to see the advantage of the other view (which is made almost useless by this No Date bug).

Note that some applications (e.g., MS Office) do not let you change the Auto-arrange setting. Just open up some other application that does (e.g., Chrome) and set it there (just go to Open File or similar -- you don't have to actually open the file). This action seems to set this setting globally (on 10.8.4).

This problem is all over the web. Why does Apple not comment on it? Does it not care about its users? Why does it not release a fix? Is iTunes so much more important? This bug seems almost ludicrous: The arrange-by setting used for categorization is (normally) "Date Modified", and the actual modified date is clearly shown in the Date Modified column. Indexing in the general case perhaps needs to happen not in real time (e.g., if you are viewing "All Files"), but when we open a dialog, can't just the (usually very few but most important) No Date files be manually indexed in that moment?

| improve this answer | |
  • 2
    It is now 2015, almost 2016. Has Apple made any fix to this? Or is this workaround the only viable option? Completely agree with givo -> why won't Apple fix these ludicrous counterintuitive configurations!?!?! – lobi Nov 11 '15 at 16:21
  • 1
    Note that sorting by Date Created seems to have fixed this for me also. – lobi Nov 11 '15 at 16:25
  • 1
    Im still having the issue. macOS Sierra 10.12.6 – jakobdo Aug 5 '17 at 8:35
  • 2
    Im seeing it in Mojave, 10.14.04 – drevicko May 27 '19 at 22:29
  • 2
    It's not a solution. Six years and three months later (!!) this bug -- and that's what it is, a bug -- still exists. – Michael Olenick Jul 29 '19 at 12:26
3

First, Force quit Finder. You can do this by pressing the option+command+esc keys and then selecting Finder from the list and clicking on the Relaunch button.

Then, try deleting the Finder's preferences file: com.apple.finder.plist, found in ~/Library/Preferences.

rm ~/Library/Preferences/com.apple.finder.plist

This file seems to easily become corrupt. Trashing it is a good first step when Views become wacky—anything to do with Finder.

| improve this answer | |
  • 1
    This didn't work. – User Oct 15 '15 at 23:53
  • I relaunched after deleting the file and it worked for me. – Surekha 2 days ago
3

Understanding the reason for this bug may help people handle it. The bug occurs when applications have been opened on a previous day and stay open overnight. If you use the application on the next day, it'll show files with "no date" because - in the context of that application - the file has been created in the future.

A workaround is to close the application in which you use that "Open" or "Save" dialogue and open it again. This bug is very annoying and I can't understand why Apple doesn't fix it.

| improve this answer | |
  • Whoa. You just blew my mind. And now I realize this is happening to me because I haven't close Chrome in seven months. – JerSchneid Jun 26 at 19:39
-1

Just click on Today, and it should update the downloads to their correct date.

| improve this answer | |
  • Didn't work. OS X El Capitan 10.11.6 – Will Sheppard Jan 5 '18 at 11:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .