I want to create a directory 'administrator' in my /home/ directory but it won't allow me as it alway returns the error Operation not supported. Any ideas?

Roberts-MacBook-Pro:home robert$ pwd
Roberts-MacBook-Pro:home robert$ sudo mkdir administrator
mkdir: administrator: Operation not supported

/home is used as a mount point for the automounter (see /etc/auto_master and /etc/auto_home), you can't create your own directories in there.

If you are looking for a place to store common administrator stuff shared between different administrators, create a directory in either /Users/(any admin account) or /usr/local/share and make it accessible to all members of the admin group.

  • 6
    That doesn't answer the question. What if I need to create a directory in there? Can I put something somewhere to get automounted? Can I delete the auto_home line from auto_master? – mjaggard Mar 11 '19 at 9:57
  • @mjaggard Primarily whatever makes you create a directory there is broken and needs to be fixed. A typical case is software ported from Linux which makes too many assumptions about filesystem layouts. But if you don't mind having to edit auto_master regularly after OS updates (and don't mind the risk that the automounter kicks in before you can do this and does whatever it likes with your directory) removing the line from the config file should work as well. – nohillside Mar 11 '19 at 10:07
  • So we can't match the paths with the other systems if there is any reason to do it. Aweful. – kakadais Nov 3 '20 at 5:39
  • 1
    @jungwonjin See my comment above for how to disable it. But as I said there as well: any application expecting fixed paths across different OS is broken. – nohillside Nov 3 '20 at 6:50
  • @nohillside Agree. But I don't want to disable and ruin default OS phenomenon and I believe always it's better to keep default on the same reason, /home system on linux as well. So sad- – kakadais Nov 27 '20 at 22:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .