7

In Chrome or Textedit I always accidently end up zooming with the build-in trackpad on MBA with Mountain Lion. How do I disable the trackpad function for zooming in application specific.

Looking into the com.apple.driver.AppleBluetoothMultitouch.trackpad.plist it is not clear what function is it and how do I disable it in Terminal.

From the example:

defaults write com.google.Chrome.plist AppleEnableSwipeNavigateWithScrolls -bool FALSE

I was thinking of doing the:

defaults write com.google.Chrome.plist AppleEnableZoomWithTrackpad -bool FALSE

But I do not know the actual entry name for it.

3
  • 1
    Have you determined if all apps zoom or are you wanting to not zoom in specific apps? You realize a multitouch trackpad is designed to zoom everywhere so you might need to just choose another pointing device and disable the trackpad entirely. Most importantly, you may need to list more details on what your hardware and software setup are to get a useful answer.
    – bmike
    Apr 13, 2013 at 9:22
  • Actually, I need to rephrase my question. I want to disable it in a specific applications (Chrome been one of it). Using something simular to -- defaults write com.google.Chrome.plist AppleEnableSwipeNavigateWithScrolls -bool FALS Apr 13, 2013 at 9:29
  • Probably related: apple.stackexchange.com/q/88472/9058
    – nohillside
    Apr 13, 2013 at 9:50

3 Answers 3

6

I managed to disable it using BetterTouchTool (http://blog.boastr.net/) an awesome freeware app that lets you customize trackpad gestures on a per-app basis. I just added two gestures for chrome (one for pinch-out and one for pinch-in) and assigned no action to them. BTT overrides the OS's gesture recognition and disables pinch to zoom.

The pinch-to-zoom was conflicting with the other BTT gestures I set for Chrome (rotating gesture to switch tabs), and Chrome was always resizing my web pages whenever I switched tabs with my gesture. This trick ended it.

enter image description here

1
  • 1
    Given that BTT is free and does a whole lot more it's the obvious solution to his problem. Jan 28, 2014 at 2:46
4

Trackpad zooming is an OS X wide functionality. You can enable/disable Trackpad zooming in System Preferences -> Trackpad

enter image description here

1
  • 1
    Sorry, I did not ask correctly, I only wanted to disable it for specific applications like Chrome. Apr 13, 2013 at 9:43
2
+25
defaults write com.google.Chrome.plist PinchToChangeFontSizeDisabled -bool true

OR

defaults write com.google.Chrome PinchToChangeFontSizeDisabled -bool true

I don't have Chrome, so I cannot test the syntax.

1
  • 2
    Not working for me.
    – hairboat
    Apr 21, 2015 at 20:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .