2

I work support and mainly work with PCs so my mac experience is limited. Right now one of the mac laptops we support is not utilizing the wifi at the user login screen and displaying "Network accounts are unavailable." I can login with the local admin and the wifi automatically connects as it should then, but I can't seem to jiggle anything loose to restore the wifi connection at login screen. I would appreciate any help or advice on how to restore this functionality as all of the laptop users need to be connected to the wifi for their domain accounts to be granted access on the laptop.

  • I've downloaded and installed the drivers off of lenovo's site and still no change in how the wireless functions. – Joshua Aslan Smith Apr 22 '13 at 12:04
  • → Joshua: Which version of MacOS X is running your Mac? If it is running Lion or Mountain Lion is the Wi-Fi icon in the top right corner on or off? – dan Jul 6 '13 at 14:18
  • Wi-fi icon is on, and OS version is: 10.7.5 – Joshua Aslan Smith Jul 8 '13 at 15:06
  • I think I've figured out the issue. Basically on the windows machines I support (95 % of my systems, I'm a mac neophyte too) it doesn't matter if I put the domain name as GENERICEXAMPLE or genericexample.com, but the mac seems to need genericexample.com for wifi logins to process correctly although both GENERICEXAMPLE and genericexample.com bind correctly to the domain. – Joshua Aslan Smith Jul 8 '13 at 15:11
  • → Joshua: You might be on the right way. MacOS X is based on Unix which is a case sensitive operating system. Which means that for many names E ≠ e… – dan Jul 8 '13 at 22:22
1

I presume you mean this error message:

Network Accounts Unavailable

I have had this problem in the past, due to an incorrectly configured DNS on the local machine. If it's only the Wi-Fi that the network accounts are unavailable on (as it was for me), try changing the DNS to point to the correct server for Wi-Fi connections.

networksetup -setdnsservers Wi-Fi <server-ip>
0

What kind of authentication does the Wi-Fi network use? If it's just password-based then the password should be stored in the System Keychain (check within Keychain Access) rather than the login keychain. Move it if it's not.

If it's certificate-based, you'll need to set up a login window (or system) profile to configure it: http://www.afp548.com/2013/03/07/another-way-to-enable-wi-fi-at-login-window-with-profiles/

0

You need to bind the domain to the exact domain url

First I want to thank everyone for trying to help me in comments and in answers.

Being used to windows I assumed that like windows I could bind the domain to either the exact domain url "example.com" or the domain name "EXAMPLE". While both would bind successfully for the laptop, the difference was what was causing my wi-fi login issues. By binding it to "example.com" I was able to easily login with any domain credentials.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .