3

Is there a way in Mac OS X 10.8.3 to open Google Chrome in full screen mode with dual monitors so that the Dev console appears on a second monitor?

This would seem to be the obvious and intuitive way to develop for the browser, but I wasn't able to find any hints or suggestions about how to accomplish this setup.

Many thanks.

  • Try my answer and see if that does it for you. It works for me every time now. – benekastah Aug 1 '13 at 17:17
2

Doesn't work as the implementation of Fullscreen-scaling in OSX (10.7, 10.8) currently only covers single-windows. Either Chrome provides its own implementation which could in fact display two windows over two displays, or - let's cross fingers - Apple implements this somewhere around 10.9 :)

  • Narrator: Crossing the fingers didn't, in fact, help – Joe Phillips May 20 at 18:11
2

I have (finally!) gotten this to work reliably in Chrome Version 28.0.1500.95 and OSX 10.8.4. Previously, I would only sometimes be able to get things to work in the way Matthew Helfgott described. Other times, the dev tools would just jump to its own full screen space. Here's how I got it to work every time:

  1. Try Matthew Helfgott's suggestion. If it works, throw a party.
  2. If your devtools move to their own full-screen space, take them out of full screen mode. It should drop it on one of your non-full-screen spaces.
  3. Once you have the dev tools in a normal (non-full-screen) space, move it to the monitor you want it to stick to (not the monitor chrome will be on).
  4. Click the "Dock to main window" button in the lower left to bring it back to chrome.
  5. Click that button again to undock it. It should now move to the monitor you previously chose, but stay in chrome's full-screen space.

If these instructions aren't clear enough, let me know and I can add screenshots.

  • This works, good instructions, and the best we're going to get on 10.8 I think. I've noticed this behavior randomly before in other apps (floating windows over the linen background)... I wonder if this is intended behavior of the window manager or a bug. – nicknystrom Oct 17 '13 at 14:50
  • Worked for me too. OSX 10.8.5, chrome Version 32.0.1671.3 dev – johowie Oct 22 '13 at 1:51
1

So, I tend to use Chrome for JavaScript app development, but since around version 15/17 (or there about), its not been possible to open the debugger console in a separate window in a two monitor development environment. Thing is, if you open Safari 6.0.4 (and maybe earlier) and you show the developer console, there is an option to 'detach into separate window' by clicking the multi-monitor icon beside the close button to the left of the console. The fault here seems to be Google IMHO. Don't know what happened and have filed a bug about it but will add if I do. Hope that helps a little.... otherwise, if you're committed to Chrome and not concentrating on user experience, you can dock the console to the right hand side of the page you are looking at. That way you get a potentially buggy DOM, but at least you can inspect your code on a running page. Ok. In fact that sucks, but it might help until Google get it sorted out.

  • Is this a no or a workaround or just commentary that we could move to the comments section of the question? – bmike May 4 '13 at 20:38
  • What do you think?? Obviously not a lot, but that not my problem. Its not a matter of implementation of fullscreen scaling in OSX 10.7/10.8, it can be done in Safari, and until it gets fixed, the compromise is to dock the console to the page in Chrome in a way that unfortunately interferes with UX development. Not repeating again. – VLostBoy May 5 '13 at 11:44
  • The addition of the bug reports awesome. Your answer is getting several flags that its not an answer. I disagree with them, but commented in case you wanted to edit it. Your call and the communities call whether it should be edited to address the "is there a way" crux of the question. – bmike May 5 '13 at 12:38
1

I am able to have the browser on one screen and the dev tools in another, both filling the screens, in the following steps

  • Open Chrome browser window on one screen
  • Open dev tools
  • Click the window icon in the bottom left corner to detach the dev tools
  • Drag dev tools to second screen
  • Use the green + button in the top left or drag the corner of the window to resize to fill the screen

This doesn't use the Lion full screen but as others have said and is a common complaint this mode is unfortunately only compatible with one screen. I really hope Apple changes their tune about this soon and I hope this workaround is what you were looking for.

  • Thanks @MatthewHelfgott -- I think the answer is hopes and dreams for 10.9 ;) Your suggestion is much appreciated though. – Brian M. Hunt May 7 '13 at 17:34
0

One solution to your problem is to update to Mavericks, which has this solved but not by default.

Whats happening is that when you go full screen, Mission Control ("four fingers up" on touchpad by default I think) is creating a new instance inside of Mission Control for that full screen separate from your actual monitors. You can see this by viewing the mission control while in full screen and while not in full screen.

You want to disable this. To do so:

  • Go to "Launchpad" >> "System Preferences" >> "Mission Control"
  • Deselect "Displays have spaces"
  • You may need to log out & log back in to see the changes

Similar question at: https://superuser.com/questions/665004/how-do-you-prevent-the-dock-from-switching-monitors-in-osx-mavericks

0

Another solution that i used is to do the following -

  1. Undock developer tools to another window
  2. Open mission control
  3. Drag the developer tools app from desktop 1 to desktop 2
  4. Open chrome on desktop 1 and developer tools associated to chrome window on desktop 2
0

I've been using a third-party app called Spectacle to work around the poor window manager in OSX and get "fullscreen" windows on both monitors when debugging in Chrome.

The default key chord to maximize a window (filling the screen but leaving the task bar in view), F, let's me drag the devtools to my secondary screen and have both the main window and the console maximized on separate displays.

It's not a true fullscreen, but it's close enough.

0

You can open chrome dev tools in its own tab by visiting chrome-devtools://devtools/bundled/inspector.html.

This is often used when you are proxying traffic to the dev tools from a remote device. This is how the ios-webkit-debug-proxy works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .