I tried repairing the permissions on the boot disk, resetting the Mac, and repairing the permissions on the boot disk. All times I repair the permissions, the list of the files that needs to be repaired is the same.

What does not allow to repair the permissions? What should I do to repair the permissions on the boot disk? Should I repair them from another Mac?

  • 2
    Can you explain why you're trying to repair permissions? 99% of the times it's recommended, the initial problem isn't one that could even be caused by a permissions issue.
    – Dori
    Feb 21 '11 at 9:41
  • Since there are some directories that always going to give error messages (without actually causing errors, like nearly all "SUID-errors"), could you give an example on which files aren´t getting repaired?
    – Asmus
    Feb 21 '11 at 11:43

How do you know that your file's permissions are not OK? What output does your repair permissions print? Any errors?

You could also try running the repair from the command-line if it would make any difference:
diskutil repairPermissions /Volumes/Macintosh\ HD/

Replace the volumes name.

You could also try running that with sudo or as root, to see if it changes anything.

Edit: Actually, what you could be seeing is that some application is using the files that "need" to be repaired and thus Disk Utility can't repair them.
Try shutting all applications off and the running the repair

  • I know it because when I verify the disk permissions, I get the "Permissions differ on [filename]" error message; when I repair the permissions (either from the terminal or from the Finder), I get the same message, followed by "Repaired [filename]". The problem is that, repairing again the permissions immediately after, I get the same list of files, as if the first time the permissions were not really repaired.
    – apaderno
    Feb 21 '11 at 2:45
  • Yes, I have the same symptom with files that are currently in use. Read my edit :)
    – deiga
    Feb 21 '11 at 2:48
  • I had that problem with files being in used. The caveat is that if these files are used by daemon/launchd processes they might not be easily terminated. To workaround this kind of issue you can boot the machine from OS X Startup Disk and run Disk Utility from it.
    – ejel
    May 13 '11 at 3:27

Have you tried AppleJack ? it runs at boot time and works for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .