9

When the administrator of a wifi network changes the network password to something new, previously associated devices that have the old password saved will no longer be able to connect until they re-enter their wifi passwords.

Unfortunately OSX handles this situation in quite an unpredictable way:

Whatever happens seems to have to do with the network security protocol in use and also differ between vendors. Sometimes it will just fail silently, sometimes it pops up a "connection timed out" alert box, sometimes it seems to get stuck, forever animating the AirPort menu bar item

Is it possible to force my MacBook to forget and/or bring back the network password entry dialogue?

  • On most mobile devices, iOS & Android, it is trivial to make the device "forget" a wifi network, and on subsequently selecting it again, effectively bringing up the password entry dialogue again. (This happens very often if you frequent any number of (wifi-enabled) cafes, restaurants or public spaces.) – conny Apr 10 '13 at 13:23
7

Open System Preferences (in your Applications folder).

Select the Network pane, and in the left-hand list of sources, select Wi-Fi or AirPort (this differs in different versions of OS X).

In the lower-right hand corner, click Advanced…. A pane will pop out, and in the list of tabs at the top, either Wi-Fi or AirPort will be selected (depending on OS X). This is the leftmost tab; if it isn’t, then click on it.

You should see a list of Preferred Networks. This is a list of all the wireless networks that your Mac knows about, and thinks that it knows passwords for. Select the network which has a changed password in the list, and press the little - button which is to the lower-left hand corner of the list.

Then press OK in the lower-right hand corner of the pane, and then Apply in the lower-right hand corner of the System Preferences window.

This “forgets” the network. The next time you ask your Mac to connect to that network, it will see it as a new network and throw up a password prompt for you. Once you enter the new password, OS X will treat it as before (logging in and connecting automatically for you).

4

The only two ways I have found so far are:

  • Selecting "Join Other Network..." from the AirPort menu bar item, manually typing in the network name (can be quite tricky when the SSID contains foreign characters or whitespace), and manually selecting the correct security protocol
  • Turn wifi off, open Keychain Access, make sure you select "all" sources in the left pane, select Find, enter the network name, select all matching items from the list, Delete them (-may require authenticating as admin)

None of them are very user-frienly :-/

  • Why do you need to select "all" instead of simply "Password"? – Pacerier Sep 15 '18 at 8:54
3

I've found that forgetting the network sometimes won't help. The software that hotels seems to keep on treating the connection as already established. I've resorted to changing the MAC address (the unique hardware based ID) for my wifi ethernet interface. That forces the hotel to re-establish the connection. Don't worry - the address will go back to normal on the next reboot.

  1. Turn off wifi

  2. Open a terminal and enter: ifconfig

  3. It will list your interfaces include something along these lines:

en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 ether d2:00:3d:71:51:05 ...

  1. The six pairs of hex digits separated by colon are the MAC address. en0 is usually the primary network interface and your wifi. Tweak the last digit (e.g. by adding one to it as I have below) and enter this line into terminal to soft change the MAC address (it will prompt for your login/admin password):

sudo ifconfig en0 lladdr d2:00:3d:71:51:06

  1. Then turn wifi back on and connect to the hotel wifi. It should bring up the login prompt as if you are a new user.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .