A few days ago, Terminal.app suddenly stopped working. Whenever I open it, the little light below the icon in the dock turns on (and stays on), but no window appears. When I right-click the icon, I'm told that the application isn't responding.

What I've tried so far:

  • Restarting.
  • Trying to open Terminal from another account (same result).
  • Deleting ~/Library/Preferences/com.apple.Terminal.plist.
  • Deleting ~/.bash_* and ~/.zsh*.
  • Deleting /var/log/asl/*.
  • Banging my head against the wall.
  • Use iTerm. A black window opens, but after that I get "Application Not Responding" as well.
  • Repairing permissions from Disk Utility.

The Console works fine, but all I get when I try to open a Terminal (or iTerm) instance is something like

login: USER_PROCESS: 5991 ttys008

I'm running OS X 10.8.3.


  • It would seem that Activity Monitor isn't working either. When I open it, the windows appears, but the list is empty and the program freezes: "Application Not Responding" here as well.
  • I can log into the machine using SSH from another machine, but when I do ps it freezes.
  • You're install of OSX sounds borked... very, very borked. Has your hard drive failed?
    – Linuxios
    Commented Apr 9, 2013 at 19:32
  • The operating system it self is in fact on a SSD, but my user folder is on a HDD, but neither have failed. I think it might have had something to do with a half-finished OS X update, but that has all been sorted out now.
    – kba
    Commented Apr 9, 2013 at 19:42

1 Answer 1


Firstly, I would check to see if the issue is systemic, or related to the user account. Create a new blank user account, and then see if you can remotely log into the computer using that ID.

Then, if that works, try to su to your existing ID.

Also, try a start in single user mode. See what works there. After that, try safe mode.

Interestingly, using Terminal I get the same message in the console as you, but I don't using iTerm. Perhaps you can try iTerm and see if that works. It would narrow the issue down to the specific applications.

  • As mentioned, I have already tried with blank user account. There I get the same result - "Application Not Responding". I will try single user mode now. I already tried iTerm, but that doesn't work either.
    – kba
    Commented Apr 9, 2013 at 1:21
  • 1
    OK, so after rebooting into single user mode (which worked), I booted back into OS X and suddenly everything is working again. Now I come to think about it, I hadn't rebooted since I tried some of the stuff listed above, so that might be what triggered it, or the fact that I just briefly went into single user mode. Either way, your suggestion lead me to a solution, so I'll take it. Thank you. :-)
    – kba
    Commented Apr 9, 2013 at 1:30
  • 1
    Single-user mode runs some checks that are reported to fix mysterious issues. I've seen several posts about it, but not much official from Apple.
    – Alex
    Commented Apr 10, 2013 at 5:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .