I was using Wake on Demand (not WOL) to access my mac remotely. I was able to turn in on from LAN or internet through SSH, VNC or HTTP. The problems came when I upgraded to Mountain Lion. Initially It was working for a small amount of time after the computer was set to sleep: after about half an hour it wouldn't turn on. Then, a few weeks later, as soon as it went to sleep there was no way to wake it up. I recently upgraded to Mavericks with the hope that it would have solved the problem but nothing has changed.

I tried all the possible solutions in this article but nothing helped me. In the last updates there are some workarounds but those are not what I want: they are simply keeping the mac on with the screen off, not sleeping. Is there anyone who managed to use the real wake on demand after Mountain Lion?

Thank you.

Update: Today, after the update 10.9.2, wake on demand suddenly started working again.

  • 1
    WOD only works on local connections (AirPort base stations) – Buscar웃 Apr 7 '13 at 19:32
  • @Buscar웃 I have a Time Capsule in bridge mode which extends the network and Wake on Demand is working. The problem is that is working only from LAN and not from internet. – Rnhmjoj Apr 7 '13 at 20:41
  • You may need port forwarding if you use NAT or you're behind a firewall. – Matthieu Riegler Apr 7 '13 at 21:21
  • There is a firewall but the mac is a DMZ and those protocols are forwarded correctly. If the mac is on I can connect. – Rnhmjoj Apr 8 '13 at 10:41
  • These comments are old, when the problem was only connecting from the internet. Now is not working at all. – Rnhmjoj Jul 22 '13 at 22:54
up vote 0 down vote accepted

Today, after the update 10.9.2, wake on demand suddenly started working again.

It appears this problem has been solved for the questioner by upgrading to OS X 10.9.2.

This appears to be a widely reported problem but no obvious cause or answers are documented.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.