2

I keep my Documents in an encrypted directory in Dropbox (~/Dropbox/encrypted), which I then mount at ~/clear when I log in. On my other Macs, I have change ~/Documents to a symlink that points at ~/clear, but trying to do the same on a new Mountain Lion machine doesn't work:

Pertinax:~$ pwd
/Users/drew
Pertinax:~$ ls
Desktop         Dropbox         Music           README.markdown tmp
Documents       Library         Pictures        bin
Downloads       Movies          Public          clear
Pertinax:~$ ln -sf clear/Documents .
ln: ./Documents: Permission denied
Pertinax:~$ ls -l@hd Documents
drwx------+ 3 drew  staff   102B Apr  5 15:02 Documents
Pertinax:~$ xattr -l Documents

It doesn't appear to have odd permissions or extended attributes, so I'm stumped. I don't recall what I had done previously to make this work on my Lion and prior machines, or if I did anything special at all.

3
  • 1
    The "+" after the traditional UNIX permissions indicate an ACL (unlike the @ of an extended attribute), viewable with ls -le; all the premade subfolders of your home will have it set to "everyone deny delete", but attempting to rm -Rf it ought to succeed.
    – Ryccardo
    Apr 5 '13 at 20:15
  • @Ryccardo - You are correct! The -e flag on ls is what I was missing. Could you make this answer so that I can accept it? Apr 7 '13 at 14:51
  • There it is :~)
    – Ryccardo
    Apr 7 '13 at 18:06
1

All of the default subfolders of your home have an ACL set to "everyone deny delete" (ACLs can be viewed with ls -le and stripped with chmod -N)

ACLs still don't affect a command run as the superuser.

0

Have you thought about executing the command as sudo? I've got a similar setup on my Mountain Lion Mac where I've just deleted my ~/Documents folder and recreated it as a symlink to my ~/Dropbox folder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .