3

So my lock or "hold" button is broken and my phone turned off. My phone is plugged in to the charger and still won't turn on. Also I can't plug it into my computer because my computer doesn't recognize an iPhone as a device.

2
  • 4
    It's probably zoning out. Try shaking it for a couple of days and I am sure it will wake up.
    – Noah
    Commented Apr 5, 2013 at 19:16
  • not sure what do you expect us to do, you need to fix that phone hardware. Alternatively remote the cover from the button and use toothpick to activate it.
    – Ruskes
    Commented Apr 5, 2013 at 20:53

5 Answers 5

7

If an iPhone is off, and you connect it to a power source (either a charger or computer), it will always turn on. Since you have mentioned that this is not happening, I would conclude that there is something more serious wrong, not just that your power button is broken.

It may be the case that your phone has just 'locked-up' - try holding both the home button and power button for at least 30 seconds and see what happens.

If that fails, I would suggest taking it to an Apple Store and see what they say.

3
  • Not true here. iphone 5 Commented Feb 20, 2017 at 6:29
  • @RegisteredUser Which bit isn't true? I'm not aware of any changes that have been made since I wrote my answer.
    – grg
    Commented Feb 20, 2017 at 12:10
  • I've connected my iphone 5 to usb to my laptop AND tried connecting it to the wall outlets, but they both show this. i can't turn it on. Normally if I just tap the powerbutton it would turn on, but i can't since the powerbutton is broken Commented Feb 21, 2017 at 0:00
1

You probably need to some repairs to your hardware (iphone) Unfortunately I do not think it is you button (the plastic piece) but what is behind it.

Here are instructions where to get it and how to fix that

http://www.ifixit.com/iPhone-Parts/iPhone-4S-Power-and-Sensor-Cable-/IF115-011

http://www.ifixit.com/Guide/Installing+iPhone+4S+Power+and+Sensor+Cable/7285/1

Is it easy to do - NO !

0

If it does not turn on like if your lock button is jammed (like mine) plug it in and hold the home button. It should come on. If it doesn't come on, take it to where you got it from or a Apple Store close by.

0

The best thing to do is connect it to your charger and it would normally turn on. If not then you should consider going to Apple or change you phone.

-1

I had exactly the same problem. Turns out it had 'locked up', and to resolve it without the lock button I just disconnected, then reconnected the battery and plugged it into a power source. After that it worked fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .