In itunes under apps tab, it list all the app which i have in my itunes account. When I click on Install button of the app, button name gets changed to will install & also on the right side it shows on which page it will be installed.

When I press Apply/sync button, On top bar it shows that its syncing in 4 steps with some progress image. This 4 steps happens so quickly & shows the status as synced.

But, the app which I wanted to install never gets synced. My iPhone is not showing the new apps which it should show after sync.

Also, It fails to restore backup which I had taken some days back.

I am using, iPhone 5 with iOS 6.0.1 Mac book pro - 10.7.5 iTunes 11.0.2(26)

I tried restaring iphone, itunes, mac. But this problem is keep persisting.

Please some body help me out.


  • Any reason why you are not running the latest version of iOS on your iPhone? Commented Apr 5, 2013 at 14:02
  • As I am developer I will require the this OS version for testing my app. I will consider that as my last solution.
    – JiteshW
    Commented Apr 5, 2013 at 14:10
  • Does other stuff such as music sync?
    – Josh Hunt
    Commented Apr 14, 2013 at 7:33

2 Answers 2


Three things come to mind if you cannot update to the latest iOS or iTunes software:

  1. Look in the console logs for actionable sync errors.
  2. Try syncing from Xcode as opposed to iTunes.
  3. Restore the iOS device (declining to update the iOS level) and attempt a clean sync from iTunes. (or Xcode)

Some questions and ideas.

is it only the one app that doesn't sync? or none of them? If one (or some) of them, check the app to see if it is supposed to work for iPhone or is it listed for iPad only. These apps work for both iPad and iPhone:

enter image description here

These are iPhone only:

enter image description here

Have you ever had app syncing work on this phone? If so, what has changed?

Are you able to add other information (contacts, music, books, photos, etc)?

Are your apps enabled to sync? Look in the apps tab to see what is marked for syncing:

enter image description here

Is this your own app that you are trying to load on the phone? If so, have you registered the app with Apple iTunes Connect, and added your developer certificate to your keychain, and your relevant information (app-ids and developer certificate info) to your apps info-plist file?

To do this, you must be a registered developer, you have to log in to the developer site, and go to the App Store Resource Center.

  • Its happening with all the apps. I am not able to sync any of them. Yes, all the apps are iPhone only I had installed all of them on my iphone once. When I tried to install backup, my new contacts & photos got deleted. My app is esily getting load on iphone with developer certificates.
    – JiteshW
    Commented Apr 8, 2013 at 12:11
  • I suggest the following:. 1. check that your apps are ok following the new backup. They should live in ~/Library/iTunes/Mobile Applications. Check that they are there, owned by you as well as their permissions. Mine are 644. 2. Restart your computer and 3. Look in the console for log reports from iTunes.
    – ICL1901
    Commented Apr 8, 2013 at 12:30
  • Mobile Application folder is missing at the ~/Library/iTunes/. It shows one .db file 7 files with .localstorage & one iTunes Plug-ins folder. I tried to read device logs through xcode->organizer but not able to figure it out whts going wrong.
    – JiteshW
    Commented Apr 8, 2013 at 13:28
  • Even if the apps have been deleted, you should be able to recover them. Itunes, then Store, then purchases.. I'm not at my computer now, but it's something like that.. Also, you can tap an app icon, ctl-click and " show in finder". They may have simply been moved.
    – ICL1901
    Commented Apr 8, 2013 at 14:15
  • I have search for my apps (.ipa files) & i found them in my machine, but my real problem is not getting resolved. :(
    – JiteshW
    Commented Apr 9, 2013 at 8:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .