My MacBook Pro and my iPad wont both connect to my wifi at the same time. Right now I'm on my iPad and my MacBook has the "no Internet connection" alert...Although there's a check mark by my network name on the drop down list.

Last night when I was on my laptop my iPad wouldn't connect.

I have no idea how to fix this problem. I've tried unplugging/restarting my router as well as manually joining my network.

3 Answers 3


The router IP might not be

On your Mac go into System Preferences and select Network then Wi-Fi in the left hand list.

Just under the Status: line it should tell you your current IP address, make a note of it.

At the bottom right click on Advanced. Now select TCP/IP and Configure IPv4: should be set to Use DHCP. This pane will also tell you your router address a little further down.

Now you can point your browser to the correct IP address for your router and see what it is saying.

You can also open up Settings on your iPad and go to Wi-Fi then click on the little 'i' in a circle icon and it will tell you the IP address it is using and the address of the router.

If the IP address being used by both is the same then there's your problem.


Sometimes routers can be stingy with information. In order to get an understanding of what's connected to your WiFi (or what is not and why perhaps) I recommend the free app called Fing

And it also exists as an OS X command line app...

That will show you all the info the network has. Maybe you will find that your MacBook and your iPad have been allocated statically the same IP. In which case you either dynamically allocate IP with DHCP or change your static IP to something else.


Check your router config:

  • First check your IP and gateway IP in your laptop.
  • Open browser and type in gateway IP:

  • Login using your router username/password (Default - admin/admin or admin/password)
  • Check for router status and click on it
  • Inside router status can you see IP address, gateway & DNS set?
  • If not then you need to config the router

Let me know how it goes.

  • When I tried the gateway ip nothing happened...it just timed out Apr 5, 2013 at 0:53
  • I should add I don't see the dns set. I don't even think I see the router but I'm not good with these things Apr 5, 2013 at 1:02
  • Is the config set for dynamic or static? If static try changing to dynamic. Also try adding gateway ip to dns and see if it works (add only when you are using static ip). Apr 5, 2013 at 2:10
  • There are many more "Default" Ip's. or 2, etc.
    – Rob
    Jan 16, 2014 at 14:22
  • You cannot assume that is the router IP and that it has a web interface. Aug 9, 2018 at 22:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .