1

I am having problem about the iPad wifi connection to adhoc (by win7) with static IP. The procedure is:

  1. Connect to the Internet with wired local network connection (autoconfiguration, ip:192.168.1.100);
  2. Enable the sharing of local network connection;
  3. Setting the wifi interface with static IP address: 192.168.2.1, netmask:255.255.255.0;
  4. Create an adhoc wifi network with WEP security, I have also tried open security;
  5. iPad connect to the adhoc wifi with the right password, with the static ip address:192.168.2.2, netmask:255.255.255.0, router:192.168.2.1, dns:8.8.8.8;
  6. After 1 minute, the setting take effective, the left-top wifi icon is shown, but, iPad just couldn't access the Internet!!!

It's weird, I have no idea how to solve it. PS: I have tried to ping 192.168.2.2(iPad) from 192.168.2.1(win7), some is ok, and some is timeout...

Does anyone know why this happens?

  • 1
    This is a Windows question about how it bridges networks – mmmmmm Apr 4 '13 at 12:33
  • Yes, you are right. I have done that with bridging the local and wireless network connection. – Yves Messi Apr 6 '13 at 5:12
  • Why not let the host machine provide the ip address for the iPad? – leo Apr 6 '13 at 22:18

You must log in to answer this question.

Browse other questions tagged .