0

I have an iPhone 4S. When I send or receive texts, my phone uses my email address and I followed instructions to switch it but it wouldn't let me click on my number to receive messages from that.

  • 1
    You might need to list what instructions you followed and which step you don't get or what OS level is running. – bmike Apr 4 '13 at 2:02
1

If you went into Settings > Messages > Send and receive, and you were not able to click on the phone number(s) listed there, this is because they are already in use.

You simply need to disable the email address by clicking on the blue arrow next to the email address listed instead and then tap "Remove this Email".

Finally, make sure to tick the correct number from the "Start new conversations from:" section.

You must log in to answer this question.

Not the answer you're looking for?Browse other questions tagged .