6

Let's say my OS X user's folder is called Attila and I have a folder with the same name in a folder, e.g. ~/Xcode/Attila/. Now, if I do a Time Machine backup, the ~/Xcode/Attila/ folder won't be copied.

Why is it? Is there a workaround to fix this?

(OS X version: 10.8.3)


EDIT

tmutil removeexclusion doesn't seem to work in this case:

enter image description here


EDIT 2

Might not be relevant, but my user account was migrated from a Time Machine backup.

  • Are there other folders in ~/Xcode which do get backuped? What happens if you rename ~/Xcode/Attila and trigger a new backup? – nohillside Apr 4 '13 at 6:11
  • Can you reproduce this in any other folder than ~/Xcode? I just tried with ~/temp/username and got [Included] /Users/username/temp/username. – lupincho Apr 4 '13 at 7:06
  • @patrix: Renaming doesn't help. I've tried ignoring other folders, and removeexclusion doesn't seem to take any effect on either of them. – Attila H Apr 4 '13 at 7:16
  • @lupincho: I'll give it a try when I'll be at home later today! – Attila H Apr 4 '13 at 7:17
  • 1
    @lupincho: every folder that has the prefix "<username>" is excluded. – Attila H Apr 4 '13 at 17:19
2

I am assuming you have already checked in in System Preferences > Time Machine > Options to ensure those folders have not been excluded?

We can then use the tmutil utility to find out some more information about this.

From Terminal enter this command:

tmutil isexcluded ~/Xcode/Attila

This will tell you whether it has been excluded from Time Machine backup or not. If it lists

[Excluded]    /Users/Attila/Xcode/Attila

You can then remove it from the exclusions list by running

sudo tmutil removeexclusion -p ~/Xcode/Attila

For more information on tmutil, check out its documentation

| improve this answer | |
  • Pre-Mountain Lion will list an excluded item as - /Users/Attila/Xcode/Attila – Josh Hunt Mar 30 '13 at 13:24
  • After sudo tmutil removeexclusion -p ~/Xcode/Attila the item is still in the list marked as [Excluded], even when using /Users/Attila/Xcode/Attila. (Btw, running 10.8.3) – Attila H Mar 30 '13 at 16:11
  • (I've added a screen capture to my question.) – Attila H Mar 30 '13 at 16:24
  • Hmm... Well at least that does help us out. We know that time machine is actively ignoring it (rather than a bug). Try without the -p flag. Also, perhaps it's the Xcode folder that is excluded? – Josh Hunt Mar 30 '13 at 16:36
  • The Xcode folder is included. (No ignored folders are shown in System Preferences > Time Machine.). removeexclusion doesn't even work without the -p flag. – Attila H Mar 30 '13 at 16:44
2

I had a file called Attila.sparsebundle in my home directory. Renaming it to something that's not related to the username solved the issue.

| improve this answer | |
  • Having a similar issue, TM is not backing up a path on an external volume named 'data'. /Volumes/data/* is being backed up except for /Volumes/data/home which isexcluded. Other than being named "home" there is nothing special about this folder or permissions compared to the other paths on the data volume. Removing the exclusion with tmutil does not change the reported state. There are no 'sparsebundle' files anywhere on the volume nor the boot volume. Yet, /Volumes/data/home is not being backedup. Renaming the folder to e.g. 'homee' causes it to be not isexcluded. WTF !? Yosemite 10.10.2 – tribalvibes Mar 14 '15 at 20:37
  • 1
    Turns out the "standard exclusions" include /home, /dev and /net on all volumes, not only the boot volume. Oops. See /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.plist – tribalvibes Mar 14 '15 at 21:05
0

Is FileVault or home folder encryption enabled?

Saw a mention of it at:

https://superuser.com/questions/53961/time-machine-no-longer-backs-up-changes-to-files-in-home-folder

If that is the case, then logging out of that account and into that of another user whose account isn't FileVault'd, you should be able to trigger TimeMachine and see the home account backed up.

| improve this answer | |
  • FileVault is not enabled. – Attila H Apr 11 '13 at 6:24
  • 1
    Hmm.. interesting. Going to try to simulate this on my other Mac tonight and see if I can't replicate the error. – Wing Tang Wong Apr 11 '13 at 17:17
  • @AttilaH btw, which version of Mac OS X are you using? – Wing Tang Wong Apr 11 '13 at 17:30
  • Mountain Lion 10.8.3 (It is included in the question...) – Attila H Apr 11 '13 at 18:18
  • Have you tried it? – Attila H Apr 12 '13 at 10:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .