4

I've already approached the Evernote staff and it appears to be a local problem on my Mac (OS X 10.7.5), so I'm taking it to this forum.

The problem in a nutshell: the menu in my Evernote is different from that of the actual release. In addition to that, shortcuts are assigned mysteriously.

Things I've tried:

  • Cleared all global keyboard shortcut assignments.

  • Deleted and re-installed Evernote from app store: Same problem.

  • Ran AppCleaner and re-installed Evernote from app store: Same problem.

  • Deleted Evernote from my keychain and did all steps above: Same problem.

Here's the discussion on the Evernote Support site. Screenshot below for a quick view:

enter image description here

The latest Evernote release only has Paste (cmd-V) and Paste As Plain Text (cmd-shift-V). I don't know where my system is getting an additional menu Paste Without Formatting. What's frustrating is that this problem prevents me from using the Paste function through a keyboard shortcut (tried assigning a global one but it doesn't work).

There is nothing that overrides "Paste" in my Global Application shortcuts. I've even unchecked everything in the other shortcut tabs.

enter image description here

Any idea what's creating this problem, and how I can address it?

Update: It appears to be an account-specific problem. Created a second administrator account, there all the menus were right. Chances are, something in my profile continues to override the menu.

Final Update: The solution should have been fairly simple: assign a new shortcut to the ghost menu item, Paste Without Formatting so that it releases its link to Cmd-V. The problem was that Evernote was reading its shortcuts configuration somewhere else. I even did a full grep of my entire Mac for the phrase above, no result. What fixed the issue? I upgraded my OS to 10.8 and voila! Evernote started accepting new shortcut assignments. That allowed me to restore the original Paste shortcut.

Thanks to everyone who helped out on this problem.

  • 1
    Can you please add the screenshots from the Evernote Forum to the post (or put them on a publicly accessible sharing site, the Evernote Forum seems to require registration to access screenshots)? Do you have any other applications installed which may mess with menus? Can you login into a different account on your Mac (set one up if needed) and check whether the problem exists there as well (to see whether we are looking at a computer or account specific issue)? – nohillside Apr 1 '13 at 15:43
  • @patrix Thanks for the interest in my problem. Screenshots added. No other application with messed shortcuts. Login with a different account: let me try that. – Ronixus Apr 1 '13 at 15:57
  • @patrix Your suggestion brought me a lot closer to the solution. On the second account, Evernote is showing the correct menus. So this appears to be an account-specific issue. – Ronixus Apr 2 '13 at 1:39
  • Does defaults read -g NSUserKeyEquivalents include the shortcut? Have you tried adding a shortcut for Paste Without Formatting or assigning Paste to ⌘V under Evernote? – Lri Apr 2 '13 at 4:41
  • Yup Lauri. I did try to override Paste and Paste Without Formatting, then restarted. No effect. :(. About that command you sent, I'll try it soon. – Ronixus Apr 2 '13 at 5:07
1
+50

I can replicate this if I set the Paste Without Formatting Menu item to have an hotkey using the system Preferences 'keyboard shortcuts'.

enter image description here

enter image description here

I set the shortcut in 'Application Shortcuts' and the chose Evernote.app rather than All Applications.

Removing the Setting will put things back to normal.

Update:

Since the OP. Confirms they once did set a global hotkey and since removed it. But the menu shortcut persist.

I re-did my global hotkey and then deleted the reference from the com.apple.universalaccess.plist file.

This resulted in the global hotkey being removed from the System preferences global shortcuts. But in Evernote the global shortcuts still appeared.

This is what the OP. seem to have.

My simple fix for this was.

Re do the global shortcuts for "Paste Without Formatting" in the System preferences global hotkeys. Giving it a new shortcut. Check to see if Evernote picked it up, which it did.

And then deleting it in the System preferences.

This removed it from Evernote.

  • I do recall that at some point before, I did set a global shortcut for Paste Without Formatting. But I removed it already. For some reason, the shortcut's effect remains. What if you try to remove this shortcut from your end, does the menu return back to normal? I'm unable to remove anything as there's nothing defined at all now. My shortcuts menu's screenshot is now there at the question. – Ronixus Apr 2 '13 at 5:02
  • 1
    See my Update in my Answer. – markhunte Apr 2 '13 at 6:34
  • Hi Mark, my sincere thanks for trying to replicate my problem. My first challenge now is in getting Evernote to pickup the new shortcut assigned. I'm trying to assign Cmd-9, but it's not picking up the new shortcut. I even deleted com.apple.universalaccess.plist, still the same. – Ronixus Apr 2 '13 at 8:37
  • Mark, I did what you mentioned on my second account and what you mentioned happened exactly as you described it. Now I have a good feeling that Evernote may be referencing a different universalaccess plist file. – Ronixus Apr 2 '13 at 8:55
  • 1
    There is an article ( reviews.cnet.com/8301-13727_7-57337941-263/… ) that hints at deleting the com.apple.symbolichotkeys.plist. My suggestion is to back the file up. And the delete the original and logout and back in. by Deleting it you may lose other shortcuts and keyboard settings. – markhunte Apr 2 '13 at 9:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .