0

I migrated an account from one Macbook to another (both Mountain Lion) using the account migration assistant. When starting the new macbook the account doesn't appear with the others on the login screen when starting up. I have to login to another account, logout and then it appears on the login screen. The login screen background also changes from white to textured grey/black background.

  • Account with administrative privileges or guest account? – Jadav Mar 29 '13 at 10:24
  • It is an Admin account. – firefusion Mar 29 '13 at 13:44
  • 1
    Are you using FileVault2? – nohillside Mar 29 '13 at 14:17
5

From OS X: About FileVault 2:

Users not enabled for FileVault unlock will only be able to log in to that Mac after an unlock-enabled user has started or unlocked the drive. Once unlocked, the drive remains unlocked and available to all users, until the computer is shut down.

In order to enable the migrated user for FileVault:

  • Log in with the account which works
  • Run Preferences, go to "Security & Privacy" and then the "FileVault" tab
  • Check for any user accounts which are not enabled yet and log them in (once)
  • for some reason this didn't help my case. my migrated user (both macs running High Sierra) does not show up on login list - even after adding to file vault and after logging in to the user at least once. I'm trying to turn off the file vault now. – Mobigital Nov 18 '17 at 22:17
-1

Disable the "Automatic log in" xxxyyy" in Users and Groups.

Based on your updated answer, there must be two active login accounts than.

Also check the Account in question, for login shell setting. In case you do not know how to do this: In Users & groups, Right click on the xxxyyy account, opens advanced options showing the login shell type.

That might also explain different startup screen.

For your Information: Normally users in OSX have their shell defined as /bin/bash.

The OS login window will actually make sure people have a usable shell before showing them on the login screen.

For example: You can disable a user — revoking both their ability to login and their appearance in the login window user list — by changing the shell to /usr/bin/false.

Apple recomeds: If your computer starts up without displaying the login window, the computer is set up to log in to a specified user account automatically.

If a computer is shared by multiple users, it’s best to set up an individual account for each user and disable automatic login. Using separate accounts protects the information and settings of each user.

Choose Apple menu > System Preferences, click Users & Groups, and then click Login Options. If the options are dimmed, click the lock icon to unlock it, and then type an administrator name and password. Click Login Options, and then choose Off from the “Automatic login” pop-up menu. The next time you start up your computer, the login window appears, and a user name and password are required to log in.

  • There is some good stuff in your answer but it may be worth to structure it a bit better so the different options are more easily recognizable. It might also help if you explain how the login shell can be verified/changed. – nohillside Mar 29 '13 at 14:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .