1

Every time I get a notification, say for my music player when a track is changed, I get that notification in the top right (standard notification center) immediately followed by "X new notifications". It happens so quickly that I don't even get a chance to see the original notification. Is there a way to mark these as read, or better yet, disable these rollup notifications?

enter image description here

1

The problem is that you are getting flooded with notifications. They're coming in so fast that the Notification Center is summarizing them instead of displaying them. So you probably should turn off some notifications.

Some apps let you select, in the application's preferences, what to notify you about. For example, Sonora probably lets you turn off notifications for every track change.

If the apps don't give you enough control, then you have to go to System Preferences -> Notifications, select the app, set the Alert Style to "None" (rather than Banners or Alerts) and uncheck "Show in Notification Center".

One way to track the source of the too many alerts is enable "Badge app icon" while disabling everything else for all the apps. Then you can look at your applications' icons and see which ones are generating huge numbers.

2
+25

Its hard for me to test, but I believe if you set the alert type to banners, and then un-tick the show in notification center then it shouldn't show the count.

  1. Open System Preferences > Notifications
  2. Select the desired app from the list
  3. Select 'Banners' as the alert style
  4. Un-tick the option Show in Notificaion Center: X Recent Items

Notifications Preferences

  • Unfortunately this doesn't seem to affect anything for me. I'm also amazed how bizarre the behavior is ... I just tried changing tracks several times in Sonora to see when it pops up the rollup notification ... first it said 7 new notifications, then one track change later, 11 new notifications – swrobel May 18 '13 at 0:12
  • 1
    Try logging out and then back in before you conclude the new settings do nothing for you. – GEdgar May 19 '13 at 3:04
  • I have logged out/back in. – swrobel May 22 '13 at 13:54
0

The only thing you can really do is to adjust the notification center settings for the particular apps. Therefore open up the notification center pane, click on the preferences button in the bottom right corner and adjust the settings in the windows that just popped up.

  • What specifically should I be changing in there? I've tried everything and it doesn't seem to affect this rollup. – swrobel Mar 29 '13 at 3:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .