0

My Macbook Pro has suddenly started acting pretty funky. I will be running Blender for a few minutes and then it will turn on the fans and they will start getting faster and faster. I checked the CPU load and I can't figure out what's happening. When I go to restart my computer It just sits there. I try to force a restart be entering:

sudo reboot

into a Terminal session. This forces the computer into the shutdown screen and it just sits there and does nothing.

I have installed BitDefender from the App store and scanned my system, nothing came up. I tried using the DiskUtil in recovery mode to verify/repair my hard drive, everything checked out. I verified all of the file permissions and there are no errors. When I boot my computer up in safe mode then it works perfectly which leads me to believe it could be a virus but I'm not sure. I have a Time Machine on my network but I haven't done a backup in a few days and I don't want to take the time to transfer all my files I need onto a flash drive.

Is it possible I have a virus, or is it some kind of system error?

0

The problem was my Time Machine backup. Here are the symptoms I got in their order:

  • Time Machine get stuck during the backup stage, gives the error "ComputerX.sparsebundle is already in use"
  • Process fseventsd started hogging CPU causing the computer to slow down
  • Computer could not restart or shut down

My sparsebundle on the Time Machine was corrupted so my computer could not complete the backup. The process responsible for maintaining the backup (fseventsd) got hung up on the currupted file and started chewing up CPU. When I tried to shutdown my computer, It would get stuck because my computer wouldn't be able to eject the corrupted sparsebundle.

I found the solution here:

In short, heres how to fix it:

1) mount your sparse bundle from your storage device
2) do a disk repair from Disk Utility, make sure your sparse bundle is selected!

Note: If your sparse bundle is not completely corrupted, you might be able to save some of your backups depending on how corrupted the bundle is

3) If your bundle is completely toast (like mine was) then you have to completely erase the bundle and start over from scratch. You DO NOT have to erase the entire backup disk, just your bundle

Note: You may have to restart your computer to clear your bundle because now that the corrupted bundle is mounted, your computer won't be able to gracefully unmount.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .