37

I am seeing attached icon in the top right menu bar. I tried deleting MenuExtras by going to /System/Library/CoreServices/Menu Extrasbut it didn't help, please help to hide or remove it.

enter image description here

58

That item is the VMWare fusion menu bar icon.

The vendor has this article and steps to allow you to disable and configure it.

http://kb.vmware.com/kb/1015330

To modify the behavior of this feature:

  1. Go to Virtual Machine > Settings.
  2. Click Application Menu (Applications in Fusion 3).
  3. Click the Applications Menu tab if using Fusion 3.
  4. From the Show applications menu in menu bar drop-down, choose Always, Never, or Only when Fusion is running.
  • 11
    In later versions of VMware Fusion this setting has been moved to the general preferences of VMware Fusion, and not related to the specific virtual machine. So from the "VMware Fusion" menu, select Preferences and the setting is now under the General tab. I have Fusion 8, I don't know when they moved this setting. – Lasse V. Karlsen Oct 12 '15 at 9:54
  • 2
    Also, go to System Preferences > Users & Groups > username > Login Items, and remove the VMWare launch application. – Patrick McMahon Mar 14 '16 at 5:08
  • When the trial period is over there is no way to access its preferences. That is one messed up call vmware. – BAR Aug 8 '17 at 6:35
13

Fusion 8

In Fusion 8, this is in VMWare's Preferences.

1. Click VMWare Fusion and select Preferences...

enter image description here

2. There will be a dropdown for Applications Menu:

enter image description here

3. Set this to Never or Only when Fusion is running

enter image description here

10

That's the VMware Fusion icon.

  1. Click it.
  2. Select "Application Menu Settings...".
  3. Modify the dropdown next to "Show Applications menu in menu bar" to be "Never".
  • Nice! I didn't realize you could control it from the icon as well. My guess is the OP has a partial install and the icon could be malfunctioning. We'll see if they need uninstall help or just pointing to the right software is all they need to solve this. – bmike Mar 27 '13 at 20:49
  • unfortunately, this doesn't work if the VM was deleted. – Sarge Borsch Nov 27 '14 at 8:41
7

It looks like the option is no longer configurable in vmware fusion 8, or maybe I didn't look in the right place. I had to kill it and rename it to prevent it from running. Haven't had obvious adverse effect yet. So, open a terminal

ps -fx | grep -i vmware
kill xxx # the pid number, such as 51889
sudo mv "/Applications/VMware Fusion.app/Contents/Library/VMware Fusion Start Menu.app/Contents/MacOS/VMware Fusion Start Menu" "/Applications/VMware Fusion.app/Contents/Library/VMware Fusion Start Menu.app/Contents/MacOS/VMware Fusion Start Menu.bak"

For someone who doesn't like command line, just rename the file, logout and login.

  • 1
    In Fusion 8, it's configured globally under general settings – john cs Dec 14 '15 at 4:38
  • This is a very bad idea, as removing that file inside the application invalidates the code signature. MacOS uses that signature to decide whether an application gets access to the keychain, iCloud and other services. Some services will just show a confirmation dialog again, others might just fail silently. Don't modify applications. – uliwitness Jul 26 '16 at 12:05
2

I had the same problem in El Capitan

I selected "Never" but the icon kept reappearing after every restart.

However, after I created my first virtual machine, the "Never" option held and the icon has remained hidden.

Sounds crazy, but true.

2

I used the following link it was helpful for VMware Fusion 8.0

Go to preferences > Show in menu bar
Select the option as per your preferences

https://www.installvirtual.com/remove-vmware-fusion-icon-from-menu-bar-in-mac/

0

I had this icon appear after log in today. I do not have any virtual machines. Another user has VMWare Fusion installed.

Here's how I solved it without messing with the installation.

  1. I used part of YH Wu's answer to kill it. If you don't understand the commands, use Wee Malcky's answer. (See below for these two methods.)
  2. Remove it from your Login Items at: System Preferences > Users & Groups > Login Items

YH Wu Method

ps -fx | grep -i vmware
kill xxx   # the pid number, such as 51889

Wee Malcky Method

  1. Open Activity Monitor app
  2. Click the CPU tab if you have one
  3. Search for "fusion"
  4. Select the process
  5. Click the Force Quit button in the top left of the window if you have it. Otherwise, try right-clicking and selection something like "Kill" or "Force Quit."
-2

spotlight -> activity monitor -> search for fusion -> kill the process

  • 2
    Forgive my negativity but while this procedure most probably will remove the icon it's rather doubtable this is the solution the OP - if not anybody - is looking for. Pulling the power plug will also remove the icon. – EDP Dec 2 '15 at 6:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .