4

I am trying to use autossh, like so:

autossh -f -i id_rsa -D 8080 user@myserver.com

However, on both an PPC Tiger eMac and a Mountain Lion MacBook Pro, I just get presented with the argument and environment variable list.

Both machines have autossh 1.4c installed. I am focused on getting it working on the Tiger machine; I only tried it on my Mountain Lion MBP to see if the issue was Tiger-specific.

  • With option -D ssh will act as a SOCKS server, is this your intent? If you try ssh -i id_rsa -D 8080 user@myserver.com, does it work as expected? If it does, if you drop option -f in autossh, does it work? If it doesn't, you will have to troubleshoot first why ssh fails. – jaume Mar 26 '13 at 15:10
6

I ran into this before and the issue for me was autossh expects a specified monitoring port (even though this is optional according to the usage stdout).

autossh -M 12345 -f -i id_rsa -D 8080 user@myserver.com

This similar command works for me against autossh 1.4c installed via homebrew on mountain lion.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .