1

The problem

I upgraded my macpro recently from OS X 10.6 to 10.8. Now (couple of weeks later) I ran an small update for OS X 10.8, and something not so funny happened.

The updater asked me to reboot my system. Before the reboot, it told me something like:

“None of the updates could be installed. An Exception occurred.”

Since that moment, whenever I try to log in, I end up in the infamous “login loop”: I enter my password, see a gray screen for about 20 seconds, and end up on the login screen again.

OS X version

$ sw_vers
ProductName: Mac OS X
ProductVersion: 10.8.3 
BuildVersion: 12D78

OS X update

The update consisted of four parts, one of them being iTunes (I think iTunes has never worked after I upgraded to OS X 10.8; this was probably an iTunes 10.6 - 10.8 upgrade or something?). The other three I don’t remember.

What I’ve already tried

  • I’ve tried to log in as another user. Same problem. So it doesn’t seem to be user-specific.
  • There are a lot of posts out there suggesting that it may have something to do with a corrupted launch service cache. There was indeed a file named “com.apple.LaunchServices-034501.csstore” (as suggested by posts below) on my machine. I removed it (in Single-User mode). Didn’t help...
  • File system check:
    • fsck_hfs -r -f -y /dev/disk1s2

Help!

The log files are too large to include here. I'll try to paste some (to my own judgement) relevant stuff in the comments below.

The OS X update took place around Mar 24 13:50. At 13:52:32 I see the first “Exit timeout elapsed (20 seconds).” (I think this is the log in timeout).

Some errors in the log file were there before Mar 24 13:50, so I guess they’re harmless (like “The following StartupItems failed to start properly”).

All help highly appreciated because I'm stuck. Also, if you know of a forum that's more suitable for this kind of problem, please let me know!

Cheers

  • The system log: helmerssoftware.com/stackexchange/system.log – Tikus Kucing Mar 24 '13 at 18:41
  • What bothers me most is the stuff between [Mar 24 13:52:23] and [Mar 24 13:52:32]. It's talking about a crash dump for WindowServer, and then you see a "Exit timeout elapsed (20 seconds). Killing" – Tikus Kucing Mar 24 '13 at 18:47
  • The WindowServer crash dump: helmerssoftware.com/stackexchange/… – Tikus Kucing Mar 24 '13 at 18:49
  • Emptied the /Library/Caches folder completely. Did not help. – Tikus Kucing Mar 25 '13 at 8:25
  • Removed the file /Users/user/Library/Preferences/loginwindow.plist. Did not help. (As you can see, I'm now at the stage of doing just hopeless attempts to repair this damn system...) – Tikus Kucing Mar 25 '13 at 8:27
0

I started OS X in recovery mode (http://support.apple.com/kb/HT4718) and chose "Reinstall OS X". This downloads OS X from the internet and reinstalls it. The download took me some 2 hours, installation another 40 minutes. Problem fixed.

I was afraid this reinstall would completely format my drive, and install OS X from scratch. But everything seems still intact. My (and all other users) home folder is still there, 3rd party apps in /Applications are still there. And everything is still working.

I never heard of this built-in Recovery System in OS X. Good to know it exists.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .