I'm trying to intall Windows 7 on my Mid 2009 Macbook Pro, however I'm running into A LOT of trouble.

My superdrive have been broken for years and I can't boot from a bootable USB. (I created one in Virtual Box using the Windows 7 USB/DVD Tool)

I then followed this tutorial on how to start the installation from within VMWare Fusion (http://www.andrewsavory.com/blog/2011/2156#), which seemed to work at first, but once I rebooted and selected the Windows Partition I got an error saying that windows could not be installed due to "recent software or hardware changes". I had selected the x86 version, so I figured I might as well try the x64 version and see if that makes a difference.

So I removed my bootcamp partition, created it again, went into VMWare after doing the same process as before, now I simply get a message saying "No operating system found".

I'm wondering with my options are to actually install Windows without a superdrive or a bootable USB. Can I just copy the installation files to the bootcamp partition and "make it start"?

  • The answer to your last question, I strongly recommend using Bootcamp's way of doing things.
    – Shane Hsu
    Commented Mar 24, 2013 at 11:04
  • @ShaneHsu Sure, I would love too, but it seems impossible, I followed all tutorials on how to create a bootable USB with bootcamp but the option just won't show up
    – woutr_be
    Commented Mar 24, 2013 at 11:17

1 Answer 1


Try using WinToFlash in creating your bootable USB.

I also ran into problems when creating a Bootcamp partition. I also don't have access to a SuperDrive when I created a Windows partition.

First, use WinToFlash on your Windows 7 iso. Please use at least a 4GB USB drive and make sure that you don't have any important files in that drive as WinToFlash will delete all files when creating the bootable USB. After creating the bootable USB, go ahead and create a Bootcamp partition in your Mac drive using this tutorial. Hope this helps.

  • The problem is that I can't boot from a USB, even though I created multiple bootable ones
    – woutr_be
    Commented Mar 24, 2013 at 10:32
  • 1
    Have you tried WinToFlash in creating your bootable USB? I had the same problem when I used the Windows 7 USB/DVD Tool in creating the bootable disk.
    – Joseph
    Commented Mar 24, 2013 at 12:52
  • Tried it yesterday, but gave me an error saying windows could not collect information for [OSImage] since the specified image file [install.wim] does not exist, but at least it booted from the USB now
    – woutr_be
    Commented Mar 25, 2013 at 1:22
  • Where did you obtained your copy of Windows 7? Have you tried using it before just to be sure that it is a working and complete copy.
    – Joseph
    Commented Mar 25, 2013 at 11:10
  • I bought it online a few months ago, I used the same copy to install it on my VirtualBox before, I'm trying it again now, maybe something went wrong in the process.
    – woutr_be
    Commented Mar 25, 2013 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .