Every time I connect my bluetooth headset to my Mac, iTunes decides it's time to launch. Is there a way I can prevent this behavior?

I found this thread, but there is no solution: https://discussions.apple.com/thread/2570254?start=0&tstart=0

  • OS X 10.8.3
  • iTunes 11.0.2 (26)
  • Using Beats Wireless

Update

Even after removing iTunes from my computer, it stills prompts me to "find iTunes" whenever a bluetooth audio device is connected.

  • 1
    check iTunes preference settings! – user44516 Mar 21 '13 at 19:04
  • If you list your headset's Bluetooth profile or just the exact model, there might be an answer by disabling the play/pause functionality that could be built into the device. – bmike Mar 21 '13 at 20:46
  • Please be more specific, and provide more detailed information. Computer type, operatings system, iTune version,... – user44516 Mar 21 '13 at 20:47
  • Updated with my info – Steve Robbins Mar 21 '13 at 23:39
  • The workaround to disable Itunes helper does not work. Ituneshelper will re appear after login even if removed. I have actually gone and found the ituneshelper.app file and renamed it and itunes continues to start when my headset is turned on! As to the workaround with terminal and renaming files that completely disabled my keyboard on my macbook air! Be very careful using this! Luckily i was able to reset the computer using a bluetooth keyboard to recover. There is really no help in this thread for OSX 10.9 using itunes. – user75259 Apr 9 '14 at 14:07

14 Answers 14

up vote 13 down vote accepted
+50

Extending Steve's answer, plus some tips from this apple discussion, here's what I did that finally solved this.

1) Create a "Do Nothing App": open Automator, create an empty application, and save it as DoNothingApp.app

2) Rename iTunes (manually in the Applications directory, or using this terminal command):

sudo mv /Applications/iTunes.app /Applications/iTunesBACK.app

3) Make a copy of DoNothingApp.app as iTunes.app (manually, or using this terminal command):

sudo cp -R /Applications/DoNothingApp.app /Applications/iTunes.app

That's it. Of course, your iTunes is now called iTunesBACK.

  • I found an an app that disables the play/pause media key. This might work for the bluetooth issue as well, and if so, it's a better solution than the one I propose above. redth.info/itunes-media-hotkey-disabler – Joe Fletcher Dec 23 '13 at 17:59
  • 3
    Won't this break updates that include iTunes? – Paul Hargreaves May 6 '15 at 20:43
  • 1
    This no longer works for me on 10.11, but @mritun's solution below does. – lyallcooper Dec 28 '15 at 13:09
  • 1
    Funnily enough, this works in High Sierra, but the one below dowsn't due to System Integrity Protection. – Virgil Jan 10 at 12:47
  • 1
    In order to get this to work with High Sierra you must first disable system integrity protection. You can do that by restarting in recovery mode (hold down cmd-R when you restart your computer), launching terminal from Utilities menu, then executing csrutil disable and restarting. – Michael DiStefano Jul 27 at 23:55

I've got this figured out.

On OSX, the "RCD" (remote control daemon) is responsible for the naughtiness. It has hard-coded list of actions to do when it detects certain "events" - one of them being connecting to a bluetooth headset.

To disable this behaviour (minimal loss of functionality, possibly your apple remote won't work), use the following two commands:

launchctl stop com.apple.rcd

launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist

This should stop rcd from being launched by OSX. No rcd - no auto-magic multimedia. Your volume keys should continue working, but things like play key (or bluetooth) auto-starting iTunes should stop. With -w option the change should be persistent.

PS: The following is the nuclear option. In Terminal, enter:

sudo chmod 000 /System/Library/CoreServices/rcd.app/Contents/MacOS/rcd

sudo pkill -9 rcd

To stop rcd from even being started by any app. To restore your rcd, use:

sudo chmod 755 /System/Library/CoreServices/rcd.app/Contents/MacOS/rcd

launchctl start com.apple.rcd

  • Finally! Something that works on Yosemite – emmby Dec 2 '14 at 20:27
  • None of these options worked for me on 10.9.5 using Beats Wireless. – acpigeon Feb 3 '15 at 0:34
  • Worked on 10.10.3 using Apple EarPods. – Pavel May 6 '15 at 16:47
  • On a MacBook Air with OS X 10.9.5, this worked (while the accepted answer of renaming the ITunes app did not, as the system would just launch the renamed app). THANK YOU. – Ghopper21 May 21 '15 at 13:45
  • 1
    Didn't work for me on OS X 10.9.5 with a Bose headset. – Eric Darchis Jul 16 '15 at 9:05

Solution explained by imp68 worked for me

Short version:

  • Remove iTunesHelper from your user's Login items

Step by step version:

  • Open "System Preferences"
  • Click "Users & Groups"
  • Select your user
  • Click "Login Items" in right panel
  • Remove iTunesHelper
  • Log off and back in (MUST DO)

and voilà !

  • 5
    I do not see iTunesHelper in my Login Items on mavericks – emmby May 7 '14 at 18:06
  • 2
    This didn't work for me in Mavericks – bluescrubbie Aug 26 '14 at 1:04
  • It is there in Yosemite, but need some time to see if disabling this really works – texasbruce Aug 16 '15 at 18:14
  • 1
    Works in El Capitan. Thanks! – deluan Jun 27 '16 at 15:31
  • 1
    I don't see iTunesHelper in Sierra 10.12.4 :( – VitalyB May 16 '17 at 8:06

I'm on a MBP with osx 10.9.2. Disabling iTunes in "CD and DVD" preferences does not help. Just renaming iTunes to something else does not work.

The service "Remote Control Daemon", rdc, is responsible for delivering commands to (for example) iTunes. Use this script, iTunesPatch. This script modifies the actual binary for rdc to inhibit the command it sends to start iTunes, which means that all other functions of rdc still works as expected.

I was also being driven mad with a new Plantronics Backbeat Pro headset, just a slight movement of the earpiece started iTunes. I found I could disable the sensors on the headset.

Go to plantronics.com/myheadset-updater. You can download a program called MyHeadset Updater. It allows you to disable the sensors. You can also download the latest firmware.

I just did this (Yes, I know this can be done in a single command, but it is clearer as two):

cd /Applications/iTunes.app/Contents/MacOS
sudo chmod 0 iTunes

And problem solved - no muss, no fuss (i.e., no prompts for "finding iTunes").

I'm guessing that this (just chmoding the actual executable) is slightly sneakier than chmoding the top level directory (/Applications/iTunes.app). I'm guessing that that prevents it from thinking you've just moved it somewhere else.

  • Nice! In one line: sudo chmod 0 /Applications/iTunes.app/Contents/MacOS/iTunes – Mirror318 Aug 16 at 0:34
  • I still get "Operation not permitted" error on 10.13 even though I'm an admin. – andrewcockerham Nov 10 at 18:06

It is completely stupid and seemingly unrelated but it works:

In the CDs and DVDs preference pane disable iTunes to launch inserted for Audio CDs

your headset is an audio cd you know ;-)

  • 4
    Didn't work for me. – Steve Robbins Apr 8 '13 at 23:38
  • Make sure you restart the computer after doing this. It worked for me after a restart on a MacBook Pro (Mid 2012), El Capitan 10.11.4. – Ben Morrow Mar 28 '16 at 19:59
  • Very simple, very easy. Worked under Sierra. Thanks. – Screenack Jun 22 '17 at 15:44

I am on a MacBook Air with Sierra, and all I had to do was:

  1. Open iTunes
  2. In iTunes Preferences choose the Devices tab.
  3. On that tab check "Prevent iPods, iPhones, and iPads from syncing automatically"

That's it!

  • This should be the accepted answer, as the others no longer seem to work in High Sierra. – stackexchanger Aug 9 at 17:06
  • Agreed, this is the best solution! – Dustin Ingram Aug 22 at 22:35
  • 1
    This solution is not the best solution; because this doesn't stop a BT device from sending a media key system service that RCD intercepts, triggering the iTunes launch. This prevents some things from triggering iTunes (e.g.: when plugging an iDevice…) but that's all it does. – Martin Marconcini Oct 31 at 19:49

Remove iTunes (you can reinstall later, but who would want to do that)

sudo rm -rf /Applications/iTunes

Create a "do nothing" application using Automator. Just open Automator, create an empty application, and save it.

Connect your device. You will be prompted to find iTunes. Click browse and select your "do nothing" application.

  • 8
    Instead of removing iTunes a simple sudo chmod 000 /Applications/iTunes.app should be enough (and avoid the reinstall later on). To revert run sudo chmod 755 /Applications/iTunes.app – nohillside May 24 '13 at 21:11
  • 1
    +1 for chmod. This worked for me on 10.9.5 using Beats Wireless. – acpigeon Feb 3 '15 at 0:34

If you open Itunes and to the left of the play bar, select the regular speakers and not the headset. This stopped auto-start for me with up to date OS and Itunes (October 2017) and Plantronics Backbeat pro 2 headset.

I've had the same issues with mine... but there is

  1. an app to route BT events to media keys
  2. an app to redirect media keys to specific apps: Media Keys by "Gear player" creator.

WORKING FIX, simplest and most effective solution (per mritunjai at https://discussions.apple.com/thread/2570254?start=75&tstart=0):

  1. Open Terminal
  2. Enter (these are two separate commands

    launchctl stop com.apple.rcd
    launchctl unload /System/Library/LaunchAgents/com.apple.rcd.plist

Thank you this is the answer! So easy!!!

Open iTunes In iTunes Preferences choose the Devices tab. On that tab check "Prevent iPods, iPhones, and iPads from syncing automatically"

so i was having this issue with my macbook where it was launching Itunes as soon as my headphone jack was plugged in.....i called Apple and they helped me disable it... here is how.

  1. OPEN FINDER
  2. GO TO APPLICATIONS
  3. HIGHLIGHT ITUNES
  4. RIGHT CLICK ITUNES AND CLICK "GET INFO"
  5. UNLOCK SHARING PERMISSIONS BY CLICKING ON THE "LOCK ICON" BOTTOM RIGHT AND PUTTING IN YOUR LOG IN PASSWORD
  6. WHERE IT SAYS "EVERYONE", SELECT THE DROP DOWN BOX AND SELECT "NO ACCESS"
  7. LOCK THE "LOCK ICON"
  8. RESTART (not necessary)AND PROBLEM SOLVED (FOR ME).

P.S. you will not be able to open itunes until you undo this process, hopes this help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.