I am working on a project remotely, and I have MACOSX 10.7.4 installed. The server is Ubuntu linux based, and I use "ssh" to access it. Recently the openSSH server in the remote server being secured by obfuscated ssh, so I have to login it with enhanced ssh command, in Windows, it's Potty software to support it. In Ubuntu Linux, it has "ssh" command with "-Z" option.

I found there is no -Z option in the "ssh" command of MacOS, so I upgrade openSSH to the latest one (6.01p1), still no this option. I am wondering why in Ubuntu linux, it's also openSSH package, but do have "-Z" option, but for the same package in MacOS, there is no "-Z" option at all?

By the way, "-Z" option will enable "ssh" to use obfuscated data (TCP header) communication. Any help is appreciated, I need a ssh client which can do support obfuscated communication.

About Obfuscated-openSSH, please check this - https://github.com/brl/obfuscated-openssh

Here is the usage displayed in Ubuntu Linux - "ssh" :

OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009
usage: ssh [-1246AaCfgKkMNnqsTtVvXxYyz] [-b bind_address] [-c cipher_spec]
           [-D [bind_address:]port] [-e escape_char] [-F configfile]
           [-i identity_file] [-L [bind_address:]port:host:hostport]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-R [bind_address:]port:host:hostport] [-S ctl_path]
           [-w local_tun[:remote_tun]] [-Z obfuscate_keyword]
           [user@]hostname [command]

Here is the usage displayed in MacOS by "ssh" -

OpenSSH_6.0p1, OpenSSL 0.9.8r 8 Feb 2011
usage: ssh [-1246AaCfgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]
           [-D [bind_address:]port] [-e escape_char] [-F configfile]
           [-I pkcs11] [-i identity_file]
           [-L [bind_address:]port:host:hostport]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-R [bind_address:]port:host:hostport] [-S ctl_path]
           [-W host:port] [-w local_tun[:remote_tun]]
           [user@]hostname [command]
  • Please, provide information about you have done OpenSSH upgrade. I have 10.8.3 and have OpenSSH_5.9p1. – Eir Nym Mar 21 '13 at 9:04
  • Hi what kind of information you want to know? – Tom Mar 21 '13 at 9:06
  • When you use ssh, the communication between client and server is encrypted, but the TCP header is not, obfuscated ssh is a way to encrypt the header, so make it more secure. – Tom Mar 21 '13 at 9:09
  • github.com/brl/obfuscated-openssh – Tom Mar 21 '13 at 9:19
up vote 6 down vote accepted

Problem sovled. You can download obfuscated-openssh and compile it in MacOS to get a new ssh command.

Download it from https://github.com/brl/obfuscated-openssh.

Download and install gcc - http://www.mkyong.com/mac/how-to-install-gcc-compiler-on-mac-os-x/

$ sudo ./configure
$ make

If there are some errors while compiling it, remember to check this https://discussions.apple.com/thread/2546848?start=0&tstart=0 (see details below)

$ export LDFLAGS="-L. -Lopenbsd-compat/ -fstack-protector-all -mmacosx-version-min=10.4 -lresolv"
$ ./configure
$ make

All done, you will have a new ssh. Check version.

$ ./ssh -v
OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011
usage: ssh [-1246AaCfgKkMNnqsTtVvXxYyz] [-b bind_address] [-c cipher_spec]
           [-D [bind_address:]port] [-e escape_char] [-F configfile]
           [-i identity_file] [-L [bind_address:]port:host:hostport]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-R [bind_address:]port:host:hostport] [-S ctl_path]
           [-w local_tun[:remote_tun]] [-Z obfuscate_keyword]
           [user@]hostname [command]
  • You are not really installing gcc but the Xcode command line tools - better to say that – Mark Mar 21 '13 at 13:38
  • You definitely prefer create formulare for home brew or Portfile for MacPorts – Eir Nym Mar 21 '13 at 19:38
  • What about heartbleed? Is there a version of obfuscated-ssh without this flaw? – user95832 Oct 16 '14 at 5:40
  • Getting configure: error: OpenSSL version header not found. – JBis Jul 12 at 13:09

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.