So I recently had IT reformat my Mac OS 10.6 laptop to put a 10.8 image on it. When I first got it back I could still access all folders in my old backups, including the Library folder under my old user account folder. Now when I go into it the system tells me that I don't have permission to access it.

I have tried sudo to get into it from terminal with no luck. I don't remember if this problem started after I enabled backups on my new install of OS X. But this is very irritating. Any ideas as to why this is? I can no longer access "/Users//Library" for example. I just get a red circle icon with a white dash in it.

I tried changing the owner with chown. I tried changing the permissions with chmod to 777. No luck so far.

Why is this happening and are there any solutions for it?



Have you tried repairing the disk permissions via Disk Utility?

If that doesn't work, try enabling the root account, logging in, and attempting to access the files.

  • Use the "System Administrator" account to access the files:

    1. navigate to the folder "/System/Library/CoreServices/" and open "Directory Utility.app"
    2. Click the padlock
    3. in the "Edit" menu, choose "Enable root user"
    4. from the Apple menu, choose "Log out"
    5. log in as "System Administrator" (or "root") and you will have access to the files in "/Users/Abby"
  • I have not tried those things yet. Thanks, I will take a look.
    – Patrick
    Mar 20 '13 at 19:29
  • Well, unfortunately the "Repair Disk Permissions" option is greyed out. I will try the second option later when I have time for logging out and in.
    – Patrick
    Mar 20 '13 at 20:49
  • Well I should have gone back and done something with this. But I switched jobs about 2 weeks after this. So I never ended up being able to complete this on that computer. I will just mark this as a good answer for the help.
    – Patrick
    Nov 26 '13 at 15:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .