2

I have a brand new mac mini 2012 connected to a Thunderbolt display. Since the Thunderbolt display was connected, I sometimes get a lagging cursor, meaning that moving the mouse/trackpad leads the cursor to follow the position very slowly. I have connected both, a Magic Mouse and a Magic Trackpad.

I'm trying to track down this issue but up to now, no avail. I've already connected another Magic Mouse, but same here.

Any idea welcome.

EDIT: if only the trackpad or the mouse is attached, it gets a bit better, but still not acceptable. I also moved around my WiFi-station and the Mac mini - not better.

  • I have the same issue. With bot my MacBook Pro (week old) as my MacBook Air. Just received a new thunderbolt cable. Still an issue. – user45648 Mar 20 '13 at 17:54
  • thanks guys for your feedback. I'm still investigating. @Ramon: do you also have both, a Magic Mouse and a Magic Trackpad connected? – brainray Mar 20 '13 at 23:49
1

Could be radio interference. Try plugging in a usb mouse and see if you have the same issue.

| improve this answer | |
2

Thanks for the hint with the radio interference, that seemed to be a large part of the problem.

In the end I did a lots of thing to get it going (consider it took like 6 hours all in all):

  • I switched to cable network in that room (almost). WiFi and Bluetooth definitely where interacting negatively. BTW: cable networking feels so much better!

  • the WiFi base-station was moved away from the Mac mini to the opposite side of the room.

  • the Magic Trackpad is switched off most of the time. It looks like there is some kind of interference between Magic Mouse and Magic Trackpad.

  • I deinstalled or updated any system preferences app, especially everything that has to do with GUI control.

Why I didn't move to a cable-mouse? I'm used to work with the swipe gesture a lot, and I'm not aware of a cable-mouse that understands Mac gestures.

| improve this answer | |
0

I've been experiencing the same issue, but with Dell Ultrasharp U2515H, MacBook Pro 13" and Magic mouse. Then I found out about SmoothMouse. It's not resolve the issue completely but it helps.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .