5

iCloud says that my password is wrong - even though I know it's right.

Here's whats happened: Yesterday, I reset my iCloud password. Got the reset email, changed password. Tried to log in to the account, didn't accept it. I thought that maybe my finger had slipped typing in the password (twice). I called support, got the reset email.

Now, here's the really, really weird thing: I wanted to make sure I got the password right - so I typed my password into TextEdit, copied it into the reset fields and reset the password. After reseting it, I immediately went to icloud.com and tried to log in using the copied password from TextEdit. The passwords are the same. iCloud won't let me in.

9
  • 1
    Is your password really really long or does it contain any special characters? Mar 19, 2013 at 23:27
  • @NathanGreenstein It's about 12 chars long. Contains one special character and a number, capita and lowercase letters.
    – Undo
    Mar 19, 2013 at 23:34
  • Have you quit your browser, dumping cache and cookies, and Restarted your machine before going to iCloud.com? I would also check your keychain entry.
    – Zo219
    Mar 20, 2013 at 0:13
  • 2
    When you copied from TextEdit, you probably inadvertently copied a empty space with it (usually before the password). check for that.
    – user44516
    Mar 20, 2013 at 15:03
  • @Borderline Nope - Even if I did, it would still have been the same for each paste - No?
    – Undo
    Mar 20, 2013 at 16:28

3 Answers 3

12

Not a solution just a verification. Since you can not see the password, that you pasted or typed I sugest to verify what is in the password field.

For that Open iCloud in Chrome In the log in paste your password- But DO NOT try to log in.

Now to make it visible do following: Right click on the password field and select "Inspect Element"

That will open a new window that looks like this

enter image description here

Move the cursor on the password field: there will be a highlighted line in the bottom window as you can see:

Right click on the highlighted line and select Edit Attribute

Now it will highlight the word "type", now you write "show" instead "type"

Magic, now it will show what is in you password field.

3
  • I am sure there is better and faster way to do this, but I am a dummy.
    – user44516
    Mar 20, 2013 at 17:59
  • I'm sure this is the best way to - really quite simple (I'm an iOS dev anyway). I'm talking to Support over the phone currently. They seem quite interested.
    – Undo
    Mar 20, 2013 at 18:43
  • 3
    Why type=>show, not password=>text?
    – bot47
    Sep 2, 2013 at 18:11
4

I got it figured out. Kind of.

After two (!) support calls to Apple, two password reset emails, and a bunch of copy and pastes later, I can get in.

I still don't know what caused it, but I suspect there was a bad network configuration of some sort on my end.

1
  • It's not a network issue on your end, it is 100% a bug. I'm a network engineer. Apr 4, 2021 at 21:36
2

I have the same problem. I tried to enter iCloud with the same Apple ID and password that I use to (successfully) log into the App store. Then I reset it. Actually there's a bug on the site that asks for your birthdate, but leaves off the year, so no matter what you put in, it's always wrong. I was finally able to reset the password. I tried logging in with the new password, but it wouldn't let me. I went to the App store and used the new password to successfully log in again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .